How to chanspy specific extension


#1

Hi,
Our Sales Manager need to listen to calls from his phone (of course he don’t have access to the command line).

I’m not sure if ChanSpy is the right tool for him, because when I tried to use it, it didn’t let me choose to which extension to listen.

Any suggestions?

Thanks!


#2

Thanks for the reply,
I’m not using whispering, just listening, and I have this problem on 1.6.2.16.1 with outgoing calls (incoming calls stays fine).


#3

There is an unresolved bug with Chanspy https://issues.asterisk.org/view.php?id=19054 that causes Whisper to fail. If you only Listen though, it should be ok I think. I am thinking of downgrading to 1.6 from 1.8 to cure this – so take care…


#4

i found more information about that,
https://issues.asterisk.org/view.php?id=18647

someone have any solution?
right now i’m running asterisk 1.6.2.16.1, the latest one is 1.6.2.17.2, but i see complains in the like above with the latest version also (so i have no reason to upgrade).

what do you think about 1.8.x ? is it much different? is it stable enough to use in a company? is it easy to upgrade from 1.6 ?

or do you have any other suggestion to fix this problem?

as always, thank you so much (:


#5

Hi there,

A nice solution for this might be to do the following:

First disable the 555 option in Freepbx. Look under Basic - Feature codes and set the feature status for Chanspy to disabled.

Next go to /etc/asterisk/extensions_custom.conf and add the following code in it:

exten => 555,1,Macro(user-callerid)
exten => 555,2,Authenticate(1234)
exten => 555,3,Read(SPYNUM,agent-newlocation)
exten => 555,4,ChanSpy(SIP/${SPYNUM))

  • notice line 2 where it says 1234, that is the password you can choose.

Hope this helps you out!


Extension listen -- How to listen to specific extensions
Secure chanspy 555?
#6

Sorry I’m Uber-n00b, the extensions_custom file was empty, I just pasted the 4 lines you wrote and it’s not working, shouls I run some command to “refresh” the extensions list?

Thanks!


#7

Great example given by James, i believe you have to put in a context, use like this; in extensions_custom.conf, otherwise you need to more stuff to get it working outside the from-internal-custom context. Note i changed the number to 5555 as it will not conflict with current FreePBX definitions.

[from-internal-custom]
exten => 5555,1,Macro(user-callerid)
exten => 5555,2,Authenticate(1234)
exten => 5555,3,Read(SPYNUM,agent-newlocation)
exten => 5555,4,ChanSpy(SIP/${SPYNUM))


#8

Now I have another problem, I’m pretty sure it wasn’t before.
Everytime I use chanspy (even when I disabled the new code and enabled the original from freepbx) it hang up all the outgoing calls (if the rep’ called the customer and not the other way).

Anybody can understand why?
That’s critical.

Thanks.


#9

Now I have another problem, I’m pretty sure it wasn’t before.
Everytime I use chanspy (even when I disabled the new code and enabled the original from freepbx) it hang up all the outgoing calls (if the rep’ called the customer and not the other way).

Anybody can understand why?
That’s critical.

Thanks!


#10

Just hit * to switch between active calls… You can also try 888 and choose which channel to listen.


#11

Hi, post your log making an outgoing call?


#12

thanks for the reply,
i changed the extension to a non default number, but it act the same on “555” also.
then i call this extension, it let me hear one of the active calls, but it doesnt ask me/prompt me to choose to which extension to listen.

any help/tip/suggestions will be great.

thanks!


#13

Chanspy is exactly the right thing to use. I think the default freePBX install uses 555 for chanspy at which point it should prompt the user as to which extension they want to listen in on. Usually the problem is that this is so open ended, anyone can listen to any conversation so it is better to write some custom piece that only allows certain uses to have this privilege.


(system) closed #14