How to change the settings of manager.conf

configuration
Tags: #<Tag:0x00007f702bfad370>

(Deutschland) #1

I want to connect phonesuite to my freepbx.

I create a user in the gui, but i can not connect from phonesuite with that account.

I found one problem in the manager.conf.
The was set to bindaddr=127.0.0.1

I have to change it to 0.0.0.0 and after that i have to fwconsole restart

After that i get a message on the asterisk Console

2020-05-11 13:18:31] NOTICE[6251]: manager.c:3512 authenticate: 192.168.x.y tried to authenticate with nonexistent user ‘phonesuite’
[2020-05-11 13:18:31] NOTICE[6251]: manager.c:3549 authenticate: 192.168.x.y failed to authenticate as ‘phonesuite’

But the useraccount is still there in manager_custom.conf .

In the manager.conf is the command
Include manager_custom.conf


(Lorne Gaetz) #2

Revert your changes to manager.conf, there is no need to edit it. Remove your edits from manager_custom.conf. Use the Asterisk Manager Users module to create your AMI user for phonesuite.
https://wiki.freepbx.org/display/FPG/Asterisk+Managers+User+Guide


(Deutschland) #3

Thanks for the quick response.

First i use the Asterisk Manager Users, but without any success.

I create the user phonesuite with a password and set permit to the ip adress of the phonesuite client.

On the cli i get nothing.

After the change in the manager.conf i get a response. And after copy the settings for the phonesuite direct into the manager.conf i can login from phonesuite.
But i get errors on the gui - no connection to asterisk