How to change the domain in the INVITE string


(Elvis) #1

Hi, I would like to change the domain in the first line of the invite for an outgoing call - eg

INVITE sip:0403778788@trunk-qld.bizphone.iinet.net.au SIP/2.0

to

INVITE sip:0403778788@bizphone.iinet.net.au SIP/2.0

I can’t work out just where settings for outgoing calls are located in the sip settings. Currently the proxy host string is what is appearing in the string.


(Elvis) #2

Replying to myself with an update. I changed to the pjsip driver.

For outgoing calls this is the sip invite that works

Authorization: Digest username=“xxxx”, realm=“bizphone.iinet.net.au”, nonce=“nonce”, uri=“sip:bizphone.iinet.net.au”,

this is the one that doesn’t

Authorization: Digest username=“xxxx”, realm=“bizphone.iinet.net.au”, nonce=“nonce”, uri=“sip:trunk-qld.bizphone.iinet.net.au”,

The only difference is that the second one is making up the uri from the “outbound proxy” setting. I have fudged that in the first example by setting the outbound proxy ip to bizphone.iinet.net.au in the hosts file.

I would prefer to not do this and this thread suggests that you can make this work with the pjsip driver.

can anyone help me with this? The server and client uri settings seem the most likely but I cannot make it work through there.


#3

Try Setting Outbound Proxy to
sip:trunk-qld.bizphone.iinet.net.au\;lr

Edit: corrected URI for proper syntax; thanks to @v8elvis


(Elvis) #4

It worked! Thanks! It’s 1am and I can go home now!

I had seen that option in some googled threads but mistakenly assumed that the gui would add in something like that when it built the string. Should really be a checkbox. Idiot me discarding a solution without even trying it. Lucky that was only an hour ago or I would feel a right goose :slight_smile:

Googling after the result found me this


with the salient part being - " Loose routing is a parameter on the URI which instructs PJSIP to not change the request URI to that of the outbound proxy. "


#6

Thanks for pointing out my mistake; I have corrected the post. Glad to hear you got it working.


(Nesta) #7

Hi Mate,

we are trying to configure Bizphone sip trunk, i was hoping if you could help us

tried using Sip or pjsip, but not successful at the moment.

any chance you can help?


#8

Using pjsip:

At the Asterisk command prompt, type
pjsip set logger on

For incoming, if the trunk won’t register, paste the Asterisk log for a registration attempt and any replies.
If the trunk registers ok, paste the Asterisk log for an attempted incoming call.

For outgoing, paste the Asterisk log for an attempted outgoing call.

Paste the logs at pastebin.freepbx.org and post the link here. If you are too new to post links, post the last 8 hex characters of the pastebin URL.


(Nesta) #9

Hi Stewart1

Thanks for your reply.

Trunk wont register, i think… im a bit new with freepbx and my tech is currently sick.

any chance you can do a quick remote session with us? happy to provide you incentive.

Yudi


#10

Go to Reports -> Asterisk Info -> Registries. If your trunk shows Registered, paste the log for an attempted incoming call, as previously described. If not, post what is shown, and paste the log for an attempted registration.

Also, paste the log for an attempted outgoing call.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.