How to change screen resolution of FreePBX?

Hi
I installed FreePBX15 on a virtual machine (Virtual Box). Now the console screen is a bit too small to work with (see screenshot below). can i enlarge this I’m not sure if it’s a problem with the VM or with FreePBX itself. I read that the resolution is changeable if ‘nomodeset’ is added to the grub startup options. Is that right? What exactly is the command I need to add?
Thx a lot.
Best regards
Louis

Either adjust the terminal size, or, better, ssh into the box.

I’d also recommend using SSH, but on other distributions this worked for me very well:

Are you on a Windows, MacOS or Linux machine?

On Linux and MacOS open the terminal and enter
ssh [email protected]_local_IP_of_your_server
the password is the root password you set during installation…

EDIT: the freePBX distro has no graphical-UI…like e.g. windows…so it is not a problem of Virtualbox!

Thanks to everyone in this thread.
I am a bit confused. I now have the desired full screen mode with two (!) VMs. :slight_smile: I’m wondering if it’s really necessary to run two VMs for full screen mode. In detail: My main operating system is Windows (this is the host). A Virtual Box VM runs on it, in which FreePBX is installed. This FreePBX CLI window is very small to work with. Also, a VMWare VM runs on Windows (host) and Ubuntu in it. I started the Ubuntu VM and entered “ssh [email protected]” (IP FreePBX server) in the terminal. Then the FreePBX server reported in full screen mode, just like I wanted it to. Do I have to keep the Virtual Box VM running with FreePBX? I think so because that’s the server. Without them, Ubuntu in the VMWare VM has no connection to the FreePBX server. Or am I wrong? Thx a lot for your patience.
Best regards
Louis

When you use ssh, you are remotely connected to your freePBX server. Yes, the VM has to be running too.

1 Like

When you run a Virtualbox machine on a computer it is like two computers. So you got to use the network and ssh into the freePBX machine.
By the way, Virtualbox uses NAT as standard setting for virtual machines. I usually change the network setting of the VM to network bridge.

Good luck!

EDIT: one more thing…when you close the Virtualbox window of the freePBX machine, there is a menu…click on shutdown with ACPI, don’t simply power it off. It can take up to 2mins to shut it down.

Thank you for your kindness. Yes, here in another thread someone wrote me that I need to set “Network Bridge”. Otherwise FreePBX did not get an IP that has the same network part as my router, which is necessary for access. If I enter the IP address of the FreePBX server in a Windows browser, the FreePBX GUI reports (screenshot below). Can I access the FreePBX CLI in the Windows browser? As? So I could save myself a VM. Why is shutting down the VM with ACPI better than just “power off”?

Of course, once you have freePBX installed, you are supposed to access it through the web-gui.
SSH is just for special situations.

The Asterisk CLI you can use in the web-gui, yes…but certain things you do through ssh.
When you close the window and press shutdown-Acpi, freePBX shuts down in an orderly manner, just as a computer shuts down.

I remembered that if I want to access the FreePBX CLI on Windows, all I have to do is open a terminal and type the ssh… command. I asked the relevant question earlier inaccurately, sorry. Thank you again for your time.
Have a nice week
Regards
Ludwig

Error:
Louis
:slight_smile:

on Windoof you need an extra tool. Are you German, Swiss or Austrian? I am Austrian :wink:

One more thing…
In Virtualbox you have a feature called snapshots. This is the ideal backup utility for freePBX. You can create as many snapshots as you want and return to previous states in case something went wrong.
I always shutdown the VM before I create a snapshot.

Ich bin Schweizer. Und ich musste erst nachschauen, ob Austrian nun Österreicher oder Australier heisst. Das verwechsle ich immer. :slight_smile:
Ich habe vorhin das Windows-Terminal geöffnet und “ssh [email protected]” angewählt, und der FreePBX-Server hat sich gemeldet. Was ich wollte, geht ja nun: der Vollbildmodus des FreePBX-Servers als CLI. Und danke noch für den Hinweis mit den Snapshots grad eben.
Have a great Life :slight_smile:
Louis

Uups…kann Windoof mittlerweile ssh out-of-the-box? Wusste ich nicht.
Früher gab’s auch immer wieder Probleme mit dem Texteditor von Windows. Der war nicht kompatibel mit Linux und hat Konfigurationsdateien zerschossen. Weiss nicht, ob das noch der Fall ist.
Ich installiere normalerweise Linux Mint auf Intel NUC Rechnern. Dort lass ich dann die freePBX VM laufen. Auf den Linux Mint Rechnern installiere ich dann die Remote Software noMachine. So kann ich wunderbar aus der Ferne meine Telefonserver verwalten.
Windows ist nicht stabil genug für einen Server!

Ciao
Reinhard