How to change path to asterisk binary?

Using FreePBX 12.0.3. I tried running “amportal restart” but it gave a bunch of error messages because it couldn’t find /usr/sbin/asterisk . We’re running on a jailed FreeBSD server where asterisk is installed to /usr/local/sbin/asterisk and I have no ability to symlink it into /usr/sbin/ .

As far as I can tell from the source code, it seems that “/usr/sbin/asterisk” and “/usr/sbin/safe_asterisk” are hard-coded in /var/lib/asterisk/bin/freepbx_engine. I had to manually edit freepbx_engine in order to get a working system. Am I missing something or shouldn’t those paths actually be detected/configurable?

In Settings, Advanced Settings once you enable “Display Readonly Settings” you have the option to specify the “FreePBX sbin Dir” which defaults to “/usr/sbin”. Perhaps this is what you’re looking for.