How to change default language for inbound routes / extensions?


I added two languages (en/de) in the Admin --> Sound Languages Menu and set the default language to de.

All inbound routes have their language set to default (I assumed the default is taken from the Sound Languages menu).

When I make an inbound call using this specific route, the language is still english. If I change the language in the route to “de” the voicemail messages are in german.

When looking more detailed into the generated asterisk config, I saw that in case of language == “de” the following line was added:
exten => 620,n,Set(CHANNEL(language)=de)

When I set the language in the route to “default”, that line was missing. The only other location where CHANNEL(language) was set is in extension.conf.
exten => s,n(setlanguage),Set(CHANNEL(language)=${SIPLANG})

I assume thats the default setting for this variable? I just don’t know where ${SIPLANG} is set, because it does not occour on any other relevant location in the asterisk configuration.

Based on this issue:
This variable can be set when anonymous sip calls are allowed. But I just want to change the default language for all Inbound Routes and not allowing anonymous sip calls.

Do I miss any configuration options?