How to auto hang up in case of "no answer"


Is there a way to automatically end a call if someone doesn’t pick up the phone within 10 seconds? I’m not talking about calls to extensions, but calls to other phone numbers, outside the local freepbx network.

Our 3 sales representatives use freepbx as a small inhouse callcenter to set appointments, but they spend too much time on not answered calls…

Hopefully someone can help me.

I’m not sure there is a built in way to do that, you would most likely need some custom script which monitored the call state and responded accordingly. Are you really losing that much time on ring no answer calls?

Advanced settings,Trunk Dial Timeout but 15 seconds is too short for a functional phone system i think 36 seconds ( six nanp rings ) minimum or you wont get voicemail etc

Thanks for your reply. How do I make such a script?

Yes, we are losing a lot of time: each sales representative spends 7 hours/week on cold calling, which is 7x3 = 21 hours/week in total. They spend 9,5 hours on the phone with decision makers (netto call time) and 3,15 hours waiting "on hold to be put through. The rest are calls with “no answer” as a result, which equals to 8,4 hours waiting for calls which are never answered. That’s 40% of the total time, which is a lot (has to do with the type of companies we contact), and could be reduced if we are able to automatically end the call after 10 seconds.

I’d try dicko’s solution first and see if that meets your needs. If not custom scripts can be written but should be tested prior to production. For the times I need to I use php and take advantage of the PHPAGI connection and use a system which is only for testing. A web search will not only provide a lot of information on php scripts but you may very well find someone else had this same challenge and there is already either a workingl solution out there.

I tried to find Dicko’s solution under “advanced settings”, but I don’t see the option there…

You might need to enable hidden settings etc. At the top

Check ‘Display Read Only Settings’ to TRUE.

Thanks so much, it’s working now! Really, thanks a lot!!!