How to allow sip calls with Allow SIP Guests and Allow Anonymous Inbound SIP Calls disable

I had to disable allow anonymous sip and disable guess in my sip trunk settings in free PBX\asterisk due to security issues and now my calls are not reaching my sip trunk. Are there any setting I need to do on the twilio side or the Astrisk side to be able to make a connection.

Twilio sends calls from five different proxies. If you have Chan_PJSIP trunk, all five IPs have to be in the match list. If you are using Chan_SIP, you have to make a trunk for each of the IPs since Chan_SIP only supports 1 IP per host.

Twilio’s documentation is very specific on using 5 IPs to send calls from.

were do I configure the ip for the trunk this is what I have for my setting

Do I add the ip address in one of these fileds?

I got it. I create a sip trunks for each twilio IP as