How to add fax capabilities to FreePBX

I am trying to add fax capabilities to my system but am getting confused. I tried enabling fax detection on an extension but it gives me this warning

ERROR: No FAX modules detected!
Fax-related dialplan will NOT be generated.
This module requires Fax for Asterisk ( or spandsp based app_fax ( to function.

I then tried downloading fax for asterisk module but couldn’t find out how to upload the module to my system.

Any idea what I need to do to get this going?

Also, I currently use It allows me to send faxes from my email by just putting the fax number as the “send to” (example: send to:[email protected]). Is is possible to send from email with FreePBX?


Is this a scratch-load or are you using a Distro? If it’s a scratch-load you need to compile spandsp before you compile Asterisk and make sure you include res_fax_spandsp.

This is a distro. I used AsteriskNOW to build the system.

What version of Asterisk now?

No. Why/how does do it? Because they won the lawsuit against the “patent” for “efaxing” Does this mean we would win the same battle? No. and we would waste thousands of dollars trying to fight it. Hooray America and your lackluster Software Patent system.

I’m using FreePBX v. 12.0.9, Asterisk V 11.12.0

Well, that’s interesting. I didn’t know had that patent. Thanks for providing the link.

Any idea how to get this to work? I have done more searching but can’t seem to find anything on this.

You could look at hylafax+/iaxmodem/t38modem and the various mail2fax scripts that that culture will expose to you, as far as I can tell they are all “prior art” and just use open source technology and effectively bypass FreePBX/Asterisk.

t38modem uses asterisk’s t38 “pass through” ability but requires a T38 compliant VSP.

iaxmodem will do T30 faxes over a good g711 connection.

both need spandsp compiled and working with asterisk compiled against it (most Distros do that if you use a Distro).

When it’s all working you can setup your mailserver to pass(pipe) appropriate mime content through a script that will use “sendfax” to send your emails to a fax machine.

If you want an http(s) GUI client, then add Avantfax to the mix.

They all work fine for me and have for years.

If you have windoze impaired clients add

and they can just “print” to your hylafax server.

That seems like a lot more than I’m looking for and a little over my head. Isn’t Asterisk set up to receive faxes? In FreePBX under each extension I have an option to receive faxes at that extension and have them emailed. My issue is that it seems to be missing a module. I need either Fax for Asterisk ( or spandsp based app_fax ( Hoe do I find and install those modules?

If you want this to be easy then you need to use the freepbx distro. Or follow the instructions provided by digium on installing res_fax

Alright, I think I’m getting this figured out. I appreciate the help do far, but still one problem.

I got a license for fax for asterisk here

That gave me these instructions to download the module. I followed them and downloaded the module, but I still get the same error from my original post. I’m wondering if it has something to do with where the module was installed. The instructions (step 5.2) told me to copy the file “” to /usr/lib/asterisk/modules. I did not have a /asterisk/modules directory in /usr/lib so I created both and placed the file there. I’m wondering if I should have put the file somewhere else and that’s why it’s not working. Are modules stored somewhere else on the AsteriskNOW system?

Nevermind, I figured it out!

I should have moved the file to /usr/lib64/asterisk/modules once I did that and it worked.

Appreciate the help!