How to accept calls from voipsoftswitch and pass it to trunk gateways connected to freepbx as trunks?

Dear All,

I have installed freepbx. I have added gsm gateways to free pbx as trunks. But I am failed to receive call from voip softswitch and pass it to my gsm gateways connected to freepbx.

Would anybody help me how can i configure freepbx so that I can make calls from softswitch to gsm gateways connected to freepbx as trunks.

softswitch to freepbx to gsm gateways(connected to freepbx as trunks)

Please help me.

Regards,
Zahid Hasan
[email protected]
+8801732997739

Zahid,

I am not sure you realize it but the way you asked your question is going to put people off and you will not get help.

You did not tell us anything about your FreePBX install (versions, Asterisk versions, OS etc.) or give us a sample of what configurations you have tried that have not achieved your results.

You simply stated your requirement then asked for help.

That’s not the way it works.

This is a community that assists other users, not tech support.

Dear SkykingOH,

I am using asterisk version 1.6.2.13 and freepbx version 2.7.0.3. This all are with elaxtix version 2.

Let me tell you what I have done in my server:

  1. Created one extension 111
  2. Added a gsm gw as trunk.
  3. added this trunk to a out bound route.
  4. Now I can call to gsm network by dialing from extension 111(using xlite)
  5. But when I send call from a softswitch, this can’t go to gsm network.

Please help me regarding this.

Regards,
Zahid

assuming your softswitch makes a sip call to FreePBX
and FreePBX passes the call to your GSM gateway:

  1. prefix the softswitch calls with a unique identifier i.e. 0723#

  2. create an inbound route _0723#. on the FreePBX system that points to your GSM gateway trunk.

Dear Dcitelecom,

You are exactly right what I am trying to do. Thank you very much for your understanding.

  1. Softswitch calls to freepbx with a prefix of 8801XXXXXXXXX (e.g. 8801732997739)
  2. Now please help me creating an inbound route 8801 that will point to my gsm gateway trunk.

Thank you very much for your kind information.

Regards,
Zahid Hasan

You have to use FreePBX 2.8 or later to set a trunk as a destination for an outbound route.

Dear SkykingOH and dcitelecom,

Thank you very much for your advise.

I have added a gsm gw as a trunk to fpbx as i said before. Created an outbound route for this. Also created an incomming route which points to gsm trunk. Now when I make a call from my softswitch, it always shows busy here. please check the following lines…

Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]from-sip-external:1] NoOp(“SIP/114.141.208.30-00000011”, “Received incoming SIP connection from unknown peer to 8801732997739”) in new stack
– Executing [[email protected]:2] Set(“SIP/114.141.208.30-00000011”, “DID=8801732997739”) in new stack
– Executing [[email protected]:3] Goto(“SIP/114.141.208.30-00000011”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/114.141.208.30-00000011”, “1?checklang:noanonymous”) in new stack
– Goto (from-sip-external,s,2)
– Executing [[email protected]:2] GotoIf(“SIP/114.141.208.30-00000011”, “0?setlanguage:from-trunk,8801732997739,1”) in new stack
– Goto (from-trunk,8801732997739,1)
– Executing [[email protected]:1] NoOp(“SIP/114.141.208.30-00000011”, “Catch-All DID Match - Found 8801732997739 - You probably want a DID for this.”) in new stack
– Executing [[email protected]:2] Goto(“SIP/114.141.208.30-00000011”, “ext-did,s,1”) in new stack
– Goto (ext-did,s,1)
– Executing [[email protected]:1] Set(“SIP/114.141.208.30-00000011”, “__FROM_DID=s”) in new stack
– Executing [[email protected]:2] Gosub(“SIP/114.141.208.30-00000011”, “app-blacklist-check,s,1”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/114.141.208.30-00000011”, “0?blacklisted”) in new stack
– Executing [[email protected]:2] Set(“SIP/114.141.208.30-00000011”, “CALLED_BLACKLIST=1”) in new stack
– Executing [[email protected]:3] Return(“SIP/114.141.208.30-00000011”, “”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/114.141.208.30-00000011”, “0 ?Set(CALLERID(name)=111)”) in new stack
– Executing [[email protected]:4] Set(“SIP/114.141.208.30-00000011”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [[email protected]:5] Set(“SIP/114.141.208.30-00000011”, “CALLERPRES()=allowed_not_screened”) in new stack
– Executing [[email protected]:6] Goto(“SIP/114.141.208.30-00000011”, “ext-trunk,3,1”) in new stack
– Goto (ext-trunk,3,1)
– Executing [[email protected]:1] Set(“SIP/114.141.208.30-00000011”, “TDIAL_STRING=SIP/GOIP157”) in new stack
– Executing [[email protected]:2] Set(“SIP/114.141.208.30-00000011”, “DIAL_TRUNK=3”) in new stack
– Executing [[email protected]:3] Goto(“SIP/114.141.208.30-00000011”, “ext-trunk,tdial,1”) in new stack
– Goto (ext-trunk,tdial,1)
– Executing [[email protected]:1] Set(“SIP/114.141.208.30-00000011”, “OUTBOUND_GROUP=OUT_3”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/114.141.208.30-00000011”, “1?nomax”) in new stack
– Goto (ext-trunk,tdial,4)
– Executing [[email protected]:4] ExecIf(“SIP/114.141.208.30-00000011”, “1?Set(CALLERPRES()=allowed_not_screened)”) in new stack
– Executing [[email protected]:5] Set(“SIP/114.141.208.30-00000011”, “DIAL_NUMBER=s”) in new stack
– Executing [[email protected]:6] GosubIf(“SIP/114.141.208.30-00000011”, “1?sub-flp-3,s,1”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/114.141.208.30-00000011”, “0?Set(TARGET_FLP_3=88)”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/114.141.208.30-00000011”, “0?match”) in new stack
– Executing [[email protected]:3] Return(“SIP/114.141.208.30-00000011”, “”) in new stack
– Executing [[email protected]:7] Set(“SIP/114.141.208.30-00000011”, “OUTNUM=s”) in new stack
– Executing [[email protected]:8] Dial(“SIP/114.141.208.30-00000011”, “SIP/GOIP157/s,300,”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called GOIP157/s
– SIP/GOIP157-00000012 is making progress passing it to SIP/114.141.208.30-00000011
– Got SIP response 486 “Busy Here” back from 182.16.142.157:5060
– SIP/GOIP157-00000012 is busy
== Everyone is busy/congested at this time (1:1/0/0)
– Executing [[email protected]:9] Set(“SIP/114.141.208.30-00000011”, “CALLERID(number)=111”) in new stack
– Executing [[email protected]:10] Set(“SIP/114.141.208.30-00000011”, “CALLERID(name)=eyebeam”) in new stack
– Executing [[email protected]:11] Hangup(“SIP/114.141.208.30-00000011”, “”) in new stack
== Spawn extension (ext-trunk, tdial, 11) exited non-zero on ‘SIP/114.141.208.30-00000011’
– Remote UNIX connection
– Remote UNIX connection disconnected

Please advise me what can I do now.

Regards,
Zahid

The rout does not match the DID, do you guys read these logs before you paste them?

[quote]Executing [[email protected]:1] NoOp(“SIP/114.141.208.30-00000011”, “Catch-All DID Match - Found 8801732997739 - You probably want a DID for this.”) in new stack
– Executing [[email protected]:2] Goto(“SIP/114.141.208.30-00000011”, “ext-did,s,1”) in new stack
– Goto (ext-did,s,1)[/quote]

Your inbound route should be “8801."
That’s all characters inside " " including the "
” character!

Dear SkykingOH and dcitelecom,

Thank you all very much. Finally it is solved. Thanks for your kind co-operation.

Briefly thats all I have done…

  1. Added gsm gw to freepbx as trunks.
  2. This trunk has been included to outbound route.
  3. Created an inbound route which points to gsm gw trunk.

Note: I have allowed anonymous SIP incomming connection to this GW. But I think it should be disabled for security and I need to allow external softswitch IP in freepbx so that calls from only this specific IP should be allowed while others will be discarded.

Regards,
Zahid Hasan
+8801732997739

Hello SkykingOH and dcitelecom,

Would you please tell me how can edit voice codec payload size. By default it is 20ms. I have searched asterisk configuration files but did not get this option.
I also want to enable silence suppression/VAD.

I am looking forward to hearing from you.

Regards,
Zahid Hasan