FreePBX | Register | Issues | Wiki | Portal | Support

How does PBXact work with Zoho and Unable to generate MOTD?(Solved)


(James Zhu) #1

Hello:
we have a pbxact-40, I wants to connect zoho CRM by CRM module. my pbxact is version 10.13.66-21, and connect with zoho by URL. But the dos in wiki shows that I have to connect zohu by Auth Token:
https://wiki.freepbx.org/display/FPG/Setup+for+ZohoCRM
My question is how can i upgrade my pbxact?
I use command to upgrade without sucess, the version still 10.13 version, not 14 version.
Any suggestion?
thanks!


(Lorne Gaetz) #2

Hi James:

PBXact 10.13 upgrades are done from System Admin -> Upgrades. When you are fully up to date, make sure you have a full backup off the system, then you can upgrade using the instructions on this page:
https://wiki.freepbx.org/display/PPS/Upgrading+from+FreePBX+10.13.66+to+SNG7


(James Zhu) #3

Hello:
I follow the link, but the system crashed. when I use USB to reinstall it, the sysem shows this error:
## ** CRITICAL SYSTEM ERROR ** Unable to generate MOTD. The /usr/sbin/fwconsole file is not accessible. You are likely to experience significant system issues

the fwconsole is in the directory, and I tried re install by USB many times, and every time it took few hours and I could not see any final indication to tell me the system have been installed successfully by USB. So, I have to plug up the USB after few hours and reboot the system. when I reboot it, the system always shows the error as above.
Do you have any suggestion?!
Reboot shows erros-Unable to generate MOTD:


During install step, always cursor and has no final indication:


(James Zhu) #4

I think I misused USB, the problem has been solved. I re install freepbx ISO and run : fwconsole sysadmin activate XXXX . It backs normal pbxact.

thanks!