How do I eliminate "You are currently the only person in this conference"

I’m using the latest non-beta Distro (FreePBX 2.9 and Asterisk 1.8).

I want to set up a conference room where the only sounds heard are the joining and leaving noises (“tada” noise). I’ve found that no matter what settings I use, the first person to join the conference will also hear “you are currently the only person in this conference.” I do not want that sound to play, even when the conference is empty.

If I set the conference to “quiet mode,” that voice will not play, but the join and leave sounds are also not played.

Can anyone tell me which files to edit to manually remove the playing of this file when joining an empty conference room?

Bump. Anyone?

Are you saying that if you set “User Count” to no it still announces the number of users?

Yes and no.

If you set “User Count” to “No,” it still plays a message telling the first arriving user that "“you are currently the only person in this conference.” Subsequent users are not given a user count.

You may have to manually do the changes. Call into the conference again and carefully watch the asterisk CLI. Find the lines that tell you that you were sent to the conference like below:

– Executing MeetMe(“SIP/abc-08f38-1”, 1234|pxXqd1") in new Stack

Look for the “1” in the options part of MeetMe. You need this to be there to disable “you are currently the only person in this conference”. Search the dialplan and menually add “1” along with the other options of meetme then do a reload and you are ready to go.

Mr. Walker,

Thanks for the response!

Can you give me a hint at which file I need to search to edit the dialplan?

I understand basic Linux, i.e.

I can login as root, cd /etc/asterisk, nano filename, make changes, save, and amportal restart. But,

  1. I don’t know the filename I need (or even part of the filename)

  2. I assume that whatever file I need to edit is auto-generated by FreePBX, and so I really need to edit one of the FreePBX files. Any idea which one?

Perhaps I should generate a bug report on this? It seems that if you disable the user count, it should prevent this message from coming up as well?

I also considered just renaming the audio file, and hoping that if Asterisk can’t find the file, it won’t play it. :slight_smile: