How do I configure music-on-hold for call-holding?

Hi,

I’m using the freepbx-distro with freepbx 14 and linux 7.3. I don’t know where to configure music-on-hold, that is played when the call is holding. When I configure MOH on the extention module then the music isn’t played when the call is hold but when I’m waiting for the call being answered instead of ringing.

When I configure music-on-hold in the inbound routes module then no changes are made. Whenever I hold the call the default music is still played.

I’m using the softphones Zoiper and XLite and to hold the call I click on the hold button.
Changing music-on-hold is very important, as I’m working on a project for school where I have to install a pbx so this issue is very important to me. Please help me and thank you

You can change the “play music on hold” form ring to default or the name that you gave from music on hold menu under settings.

Like I’ve said, I have configured music on hold on both the extension module exactly at the place you’ve just explained to me and at the inbound routing module you can also configure music on hold. Both options don’t work.
With your method I hear the music when I’m supposed to hear a ring while I’m calling a number and waiting for it getting picked up. But I want to have the music while the call is put on holding. At the moment it’s still the default setting. With changing the setting in the inbound routing module nothing happens.

To be more clear what I want, the music should be played when this button is pushed:
htt ps://s11.postimg.org/8morkuz4z/ssss.png

check the section “music on hold” in Inbound and outbound routes…

nbthost: Are you an expert? At reading questions anyway? The settings Hoatzin wants are under the tab “Settings” -> “Music on Hold” There you can edit the default music, and create different ones to use for different occasions. You can upload files or use an application, which gets more complicated, beyond my level.

Good luck!

(P.S. I am not an expert, we have only started using FreePBX in the last 6 months, and I myself have only done some minor configuration.)

no need to say. it is 101…
I thought you know the menus.
Read the manual first.

start reading from:

https://wiki.freepbx.org/display/PPS/FreePBX+Distro+10.13.66+or+Older

Like I’ve said, I’ve also changed the settings at the inbound routes module but I still get the default music. I don’t need outbound calls as I haven’t added a sip trunk yet. And if you look at the screenshot I’ve sent you can see that I have choosen another music-on-hold category than default, which means I know where to create them. So I guess my problem is that changing the settings doesn`t change the music-on-hold with me. How can I solve that?

Sorry I failed to catch that detail

My problem isn’t solved yet…

There is no setting to alter the music on hold for extension to extension calls as this will always be the default MOH category. You have to edit the default MoH settings to change the music on hold that is played for extension to extension calls that are placed on hold. For calls that come in via inbound routes, the MoH can be set to a different MoH “class” or “group” that is first configured in the settings->music on hold admin area.

1 Like

7 years later :sweat_smile:

1 Like

Better late than never, LOL.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.