How do I configure a custom outbound sip call to URI

I’ve done this before with a previous version of FreePBX (13). I’ve installed a new FreePBX 14, and am trying to setup custom trunk and custom route to ZipDX.

Custom Trunk has custom dial string set to SIP/[email protected]
Custom Outbound Outbound Route is, of course, pointed at the Custom Trunk, Dial Pattern of Prefix of 99 and match pattern of “XXXXX.” (w/o the quotes). Pretty much nothing else changed.

Used to work. I did read somewhere that a) FreePBX 14 handles URI’s so you don’t have to do anything with SRVLOOKUP (which chan-sip thing anyway). Anyway, when I try dialing it, I get all circuits are busy now. And I see the following in the log:

channel.c: No channel type registered for ‘SIP’
app_dial.c: Unable to create channel of type ‘SIP’ (cause 66 - Channel not implemented)

and then I get all circuits are busy.

By the way, I used to have both Chan_Sip and PJSIP, but now I only have PJSIP.

FreePBX 14 and Current Asterisk Version: 13.22.0
Current on Maintenance.


These two statements are mutually exclusive. Your dial string is referencing a driver that is not active on your system.

I suspected that, I’m not sure what to do about it. I did a fair amount of searching around trying to fix the problem that I have and how it should be configured, but was not able to resolve my issue yet.

So, any idea about where to research or what to do?


Also, PJSIP seems to be working pretty well on my system. I had switched all of my phones and trunks to PJSIP and turned Chan_sip off for fun. I was wondering if that was related to the problem which is why I mentioned that I was PJSIP only in my original message. Thanks for your observation though. Do I need to specify PJSIP rather than SIP on that line. I did try it for fun and it didn’t seem to help.

So, is it possible to setup an outbound trunk and route so that you can call ZipDX using it’s URI on a System with only PJSIP. I had done it previously by setting up a custom trunk using SIP/[email protected], and a route that calls the outbound trunk. But it doesn’t seem to work on my system, could be related to having Chan_sip turned off. I tried PJSIP/[email protected] but I get all circuits are busy.

There must be some way of making calls via URI to services like ZipDX

First the reason SIP/xxx fails is because you have the chan_sip driver disabled. Enable it and that dial string will work. Second, it is possible to dial a SIP URI with pjsip, but it’s weird. The dial string takes the form:


You must include an endpoint name that is already defined. You can create a pjsip trunk for this purpose, or use an existing trunk/extension name with suitable config for the URI you’re dialing.

OK, it seems that what I needed to do was a) turn on Chan_SIP, b) create my Outbound route and trunk, and c) issue fwconsole restart. And now it works.

Thanks to lgaetz for pointing out that PJSIP conflicts with my setting of SIP.

This is really easy in PJSIP. Define a regular (not Custom) trunk. Set Authentication to None and SIP Server to – everything else left at defaults.

1 Like

Thank you for that one, it worked too. My instructions for my self for 2 years from now when I need to recreate it again are:

Create a Custom Trunk for ZipDX Conference

For a system w/o Chan_sip enabled, for pjsip do the following:
a) create a regular trunk (say ZipDX_Trunk as a name)
b) Set Authentication to None
c) set SIP Server to
d) set dialed number manipulation rules to prefix 99, match pattern = XX. (with the dot)
d) leave everything else default
e) save
f) create an outbound route (say ZipDX_Outbound)
g) point it at your ZipDX_Trunk
h) in Dial Patterns set match pattern to 99XX. (with the dot)
i) save
j) test it, call 99200901 or whatever 99#####

Either method works well, but this allows me to run PJSIP only.

Well, also push the big red button in the upper right corner after finishing everything too.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.