High Memory usage with Java and Asterisk

I have a small server running FreePBX The server is consuming a lot of memory, and is running very slow. When I run top, and press “o” for options, and then “n” to sort by memory I show the following output (below). As you can see Java is using 2.2GB of ram. Is this normal?

top - 13:01:21 up 1:41, 1 user, load average: 0.17, 0.11, 0.04
Tasks: 110 total, 1 running, 109 sleeping, 0 stopped, 0 zombie
Cpu0 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Cpu1 : 0.0%us, 0.0%sy, 0.0%ni,100.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 3925148k total, 3253448k used, 671700k free, 18024k buffers
Swap: 786424k total, 0k used, 786424k free, 182680k cached
1802 asterisk 20 0 2280m 138m 10m S 0.3 3.6 1:01.15 java
1689 asterisk 20 0 399m 36m 3692 S 0.0 1.0 0:14.23 httpd
1663 asterisk 20 0 1638m 32m 12m S 0.0 0.8 0:59.40 asterisk

Neither Aserisk nor FreePBX uses java look elsewhere . . .

Thanks. The freepbx distro includes it. I will uninstall it.

The FreePBX distro includes what java based service?

$ rpm -qa | grep -i jre

That merely shows that the “Java Runtime Environment” is installed. What ever you have running under that is by your choice, try from bash ps uax|grep java and post the result.

I ran the requested cmd line and found it was isymphony. We are not using it I would like to remove it from the server and was wondering if it is just done in the module admin section?

It is sufficient just to not run the service

service iSymphonyServer stop && chkconfig iSymphonyServer off

will do just that.

Dicko that worked, although our CPU usage is barely there we still are not all the way full into the systems potential.