High Availability Join Cluster Errors: Asterisk UID Mismatch and Insufficient disk space

Was having issues with the HA cluster not cutting over and performed a clean CentOS 6.6 w/ FreePBX HA install (ISO Download from FreePBX web site) and after performing all the updates I am receiving the above two errors when trying to join the fresh install to the cluster. Another thread recommended making sure HA was the most recent version because this was a bug and to perform a “Manage -> Cluster -> Run” commend on the cluster I am trying to join and this should resolve it, but I am still getting the same error. Both are running High Availability Services and both are identical servers mirroring the same hardware.

Disregard Post. Switched install from HD 250 Gig or Higher to “Advanced” and manually made the partitions to match other node’s /dev/mapper/vg_ha-slash and /boot partitions to mirror the exact same size of other node in an attempt to remedy the insufficient disk error. In addition to having that same error (e.g., insufficient disk space) I am now presented with a new error, “Version Mismatch. Cluster is version 3, should be 4.” Going to start a new topic and link it to this post.

‘Asterisk UID Mismatch’ is a severe and traumatic error. It means that the entry for asterisk in /etc/password is different on each machines.

It’s part of the system consistency check, and it should be impossible, as the installation script explicitly sets the Asterisk UID to be 499 when the asterisk user is created at system install.