I had setup Voicemail 2 Email myself 8-9 months back. It worked like a charm.

Now I am trying to do it again. It works perfectly OK if I do not change anything. I am able to send mails out to my hotmail and google account instantly.

However, in the subject line, it shows Asterisk PBX

The from Email is "[email protected]"

I want to have it changed to " Voicemail System"

The from email should be from "[email protected]"

I have changed the necessary values in the file.

Also, I have edited the file.

However, whatever I do over there, the settings do not seem to take effect.

I am using POSTFIX with TB v2.6.2.3

Also, strangely enough if I give my SMTP relay server and username/password, my emails seem to failing

What to do?

Where is the ***** (profanity removed by forum admin) is this coming from, it is not within my or Perhaps, I believe my settings are overridden

[PBX]: New message 18 in mailbox 7919726‏
From: Asterisk PBX ([email protected])
Medium riskYou may not know this sender.Mark as safe|Mark as junk
Sent: Sat 12/26/09 11:07 AM
To: Rehman ([email protected])

Dear Rehman:

Just wanted to let you know you were just left a 0:06 long message (number 18)
in mailbox 7919726 from Mohammed Wahid, on Saturday, December 26, 2009 at 10:07:00 AM so you might
want to check it when you get a chance. Thanks!


Where is this text coming from?

I have no problems in sending out email to anywhere.

However, I am frustrated with the Subject, Email body and FROM fields.

The changes that I have made to do not seem to take effect.

Here is the mail log,

Dec 26 11:24:30 sipbox2 postfix/pickup[2112]: C5793F8140: uid=102 from=<asterisk> Dec 26 11:24:30 sipbox2 postfix/cleanup[2886]: C5793F8140: message-id=<[email protected]> Dec 26 11:24:30 sipbox2 postfix/qmgr[2113]: C5793F8140: from=<[email protected]>, size=815, nrcpt=1 (queue active) Dec 26 11:24:31 sipbox2 postfix/smtp[2889]: C5793F8140: to=<[email protected]>,[]:25, delay=0.57, delays=0.15/0.03/0.26/0.13, dsn=2.0.0, status=sent (250 <[email protected]> Queued mail for delivery) Dec 26 11:24:31 sipbox2 postfix/qmgr[2113]: C5793F8140: removed

Have you looked in the voicemail.conf file for the mailbody= line?

Definitely, if you say, I can provide you access to my box.

I’ve checked the and, both of these files.

But like I said, whatever changes I make here, they do not seem to get into effect.

Where could be the current email body coming from?

I’ve done a grep -r “Just wanted” /

I don’t find this text anywhere. Where could this be?

Is this hard coded in

First, have you reloaded Asterisk after you changed the message in
Second, look at the header in the email, does it look like it is from your server?

Yes Mikael,

I’ve been using this stuff for almost 2 years now. The header definitely is from my server. I’ve already posted the email and the mail log in this thread.

I just want to where is the asterisk user writing the email prior to delivering it.

The emailsubject is in either voicemail.conf or in
If you DONT have any $emailbody= or $emailsubject= it defaults for the subject to:

Subject: [PBX]: New %s message %d in mailbox %s

And for the body it defaults to:

Dear %s: Just wanted to let you know you were just left a
%s long message (number %d) in mailbox %s from %s, 
on %s so you might want to check it when you get a chance.  

Define $emailsubject= and $emailbody= to what you want, the do a reload of the app_voicemail module so it will be read by the module.

Check that the files are with correct permissions so that Asterisk can read them.

Done! However, results were not as desired

Here are the asterisk file permissions. They seem to be OK as I have another box with the same set of permissions and there things seem to work fine.

2852562 -rw-rw-r-- 1 asterisk asterisk 747 Dec 27 01:02
2852570 -rw-rw-r-- 1 asterisk asterisk 843 Dec 27 00:33
2852571 -rw-rw-r-- 1 asterisk asterisk 189 Dec 27 00:28 voicemail.conf

Let me PM you and provide you direct access…

Great ! Now, how do I PM you here …

Check that your voicemail.conf contains this at the very first:


If it does not, add the above lines.

You the MAN !!!

Those lines needed to be appended. It works as desired now.

Since the last freepbx (2.6) update, the email content have changed.
into, I’ve this.


into voicemail.conf there’s this:

And all the permissions are right:

-rw-rw-r-- 1 asterisk asterisk 609 jan 9 12:47
-rw-rw-r-- 1 asterisk asterisk 906 jan 8 17:04
-rw-rw-r-- 1 asterisk asterisk 766 jan 9 12:37 voicemail.conf

into I’ve this:


pbxskip=yes ; Don’t put [PBX]: in the subject line
[email protected] ; Who the e-mail notification should appear to come from
fromstring=Boite Vocale ; Real name of email sender
maxmessage=180 ; max length of vm message
minmessage=3 ; Minimum length of a voicemail message in seconds
maxsilence=5 ; Wait for 5 silent seconds and end the voicemail
silencethreshold=128 ; What do we consider to be silence
skipms=3000 ; How many miliseconds to skip forward/back when rew/ff in message playback
review=yes ; Allow sender to review/rerecord their message before saving it
operator=yes ; Allow caller to press 0
nextaftercmd=yes ; Automagically play next message when current message is deleted or saved

paris24=Europe/Paris|‘vm-received’ Q ‘digits/at’ R

and the result is always:

Dear Chambre Patou:

Just wanted to let you know you were just left a...etc

it’s stupid no!!??

Why this change?
it worked well before this update! :frowning:



danardf, this is not changed by FreePBX upgrade as the file in 2.6 install does contain the correct text. I have double checked it.

What distro are you using?
How did you upgrade to FreePBX 2.6?
What was your previous FreePBX version?