Help with texting through Voip Innovations module

Having a hard time making this work right. I can send outbound texts but inbound replies just bounce back to the sender and look like the PBX is parroting it. I tried a few more this morning as I’ve been playing with the firewall and trunks with no luck.

Installing that module seems to have added all the needed IPs to the firewall.

Per VI I created a new endpoint group (existing groups can not be converted) to have SMS enabled and as type Sangoma PBX. I moved some DIDs in. On the DIDs I set SMS to SIP. After entering the key into the module on the PBX there appears to be some connectivity as I can send out from UCP and I can assign the DIDs with SMS enabled to a UCP user.

In the module next to Asterisk Registration Status it says Rejected.

VI sees the inbound texts but on their end it shows “subscriber not found” and suggested I verify the IPs are allowed through the firewall (I tried this with the firewall off completely to make sure) and to read the wiki article again.

Any suggestions?

PBX Version:
PBX Distro:12.7.8-2104-1.sng7
Asterisk Version: 16.17.0


I disabled the Allow List (unsupported) module and that seems to have fixed some of this. Asterisk Registration Status shows Registered now in the VI module and VI themselves can see that the inbound texts were accepted by the PBX.

Still nothing showing up in UCP, but i have that stupid XHR poll error still that I’ve been unable to resolve which could be part of my issue.

Where are the messages stored in the PBX? Will they show up once I get the UCP working right or are they lost if the user is not there to receive them as they come in?

This uses dialplan voodoo I wonder how it would affect registration. That is strange

Maybe it’s a coincidence but that’s the last thing I changed before the registration started working.

I think I figured this out. First off, it was not the Allow List module, someone else had synced the white list and networks list in the firewall, so apparently the VI IPs were not properly white listed. Weird that shutting off the firewall completely didn’t work.

I tried again on another server and after entering the key into the VI module it wouldn’t register until a fwconsole reload.

Second, the xhr poll error / certificate issue does not actually stop the messages from coming in, but with that error the web page won’t update in real time, meaning you need to refresh the page to check for new messages. On a server without that issue it just pops right up. So it kind of works when UCP is broken and perfectly when it’s not.


Third, another issue was the endpoint group at VI. In autopilot I had it set to strip the + from the phone number, which is wrong for SMS apparently. Looking in the asterisk full log you can see it rejecting the text because it doesn’t recognize the phone number

compared to when the + is not stripped

For good measure, here is what the endpoint group looks like in the VI portal

Have you tried MMS yet? Customer mentioned today that MMs does not work with VI as why they were porting to Cleary IP as they needed MMS and also that inbound SMS for short codes also do not work with VI.

Just curious if it was just this customer not setting up things correct of if that is truly the case. All the docs say is SMS with no reference to MMS or inbound short code messages.

*edit: here’s what I’ve done and see this morning so far

I texted a picture from my cell phone to the SMS-enabled VI DID and the text portion arrived but not the picture. It was delayed about 2 minutes. The asterisk full log shows it arrived as SMS

When the text arrived in UCP I sent another text (no attachment) from my cell phone that never did arrive.

After I posted this I decided to try it in the other direction and uploaded a picture in UCP and it did successfully send to my cell phone.

Still need to check with VI on the delay, the missing text, and if we do have the ability to receive MMS.

In case it’s important the cell phone is on ATT and the DID with VI is on O1

Are there plans to make this work with Sangoma Connect or do I need to use SIP Station to text from the mobile app?

SMS/MMS in and out thru Connect work fine for both SIPStation and VI. If you are having issues, open a Connect support ticket and we can investigate.

Where is it supposed to show up in the app? The wiki article just says what needs to be in place to use it but I dont see anywhere in the app to actually text anyone.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.