Help with Intel NUC Install

Okay so I’ve tried to install FreePBX on this new Intel NUC we have, we have a USB Drive with FreePBX 13 / CentOS 6.6 that we have installed on about 80 machines, so I knew it was working however it didn’t even try to install on the NUC box, blamed it on the new hardware and moved on.

Downloaded FreePBX 14 running CentOS 7, setup a new USB Key and went on my way, got the Critical System Error: Unable to Generate MOTD, The /usr/sbin/fwconsole file is not accessible

Went back and did a fresh install on the USB Drive again, maybe a bad download, while I did that I updated the BIOS to the latest release, and re-setup the bios for Legacy boot, ACHI handling of the SSD, disabled things I didn’t need, like bluetooth etc.

Ran the installer again and I noticed something, it’s not detecting my LAN Card, or the Wireless card… LAN Cable is plugged in and activity lights are on but nothing, and at the end of the install I get the same error, I’m assuming because it can’t connect to the internet

Please help, I know people have installed on these before I’m just having rotten luck today!

Model: NUC7i5BNH


Not sure about this model, but we’ve had in the past that NIC ports were burned.
And you gotta have internet while installing…

Okay, I put in a USB 3 Ethernet adapter in and the installed picked it up and doing an install now, any downside to just running the USB 3 adapter?

I had similar issue before, after using DVD disk instead of usb drive, the installation successful.

Good luck!

The upside is it’s working. No downsides I can think of. I’m doing the same thing on a couple other servers and never had a problem.