Help with Extensions


I’m having a problem with my extensions. When people call certain extensions that may be idle, it doesn’t ring on the phone instead it plays the unavailable message. Unplugging the phone and replugging it in stops the problem but it seems like it may be if the phone goes “idle”. Does anyone know why this is happening or at least a work around.

Thanks in advance,

when the phone does not ring please verify that the phone is registered at that point. If not what you are describing is exactly what will happen.

How about some more details please, or would you prefer that people guess?

The phones are registered when they do not ring. When the extension is called it goes straight to the unavailable message, but I can place calls out from the phone. I have tried toggling the DND but that does not fix the problem. The only way to fix the problem is to unplug the network cable and plug it back in. The panel shows the device as on however it is somewhat shaded. After I make a call from the phone the panel shows the device as on but I still can’t get through to the extension. I am using FreePBX 2.5 with Cisco 7960 phones flashed with SIP. Is it possible that the system puts idle phones in an unavailable state? If so is there a way to shut that off?

Thanks for the help

It sounds like they are losing their registration. Are these remote extensions? (Outside your firewall)

In your SIPDefault.cnf file what is the timer_register_expires set to?

They are remote extensions outside of my firewall. I’m not sure what the setting is in the SIPDefault.cnf. I did not flash the phones. I will try to find out what they are set at. The system status never shows that the phones lose registration. The amount of phones connected always stays the same. Could it also have something to do with the server being hosted offsite?

If you check the registrations in the ‘Asterisk Info’ module (SIP Info section) I think you’ll find that they are listed as ‘unreachable’ What is happening is the remote firewall (where the phones are located) is shutting down the connection due to lack of activity–thus making the phones unreachable.

What you will want to do is change the ‘timer_register_expires’ setting in the SIPDefault.cnf to some value low enough to keep the connection alive. Try setting it at 300 (then reboot the phone) and see if that is short enough to address the problem.

I changed the phones I was having trouble with to 300. At first it appeared to work but one phone that I Changed started doing it again. It is not as often but it still goes unavailable. Other phones don’t have this problem at all and they are still set at 3600. I will try 200 and see if that helps. Any other ideas?


does this one phone that is remote have a different firewall then the rest? Some firewalls are known for causing problems.

They are all remote and all behind pfsense. I’m hoping the lower timeout will stop my problem.

Is the latency to this one phones location higher then the others? if so I’d try dropping it from 300 to say 270