Help to set a Ring Group or Queue with external numbers

Hi mates,

Covid-19 has changed our place of work, so we are telecommuting from our homes.

I have created 5 “Misc destinations” with 5 mobiles numbers, and then 5 virtual extensiones 10001-10005, those “Virtual extensions” have the “no answer” section to the “Misc Destinations”

Now i have created a Queue (600) with the 5 static agents, from 10001,0 to10005,0 (ringall strategy)

I have created an IVR 600 for the Queue 600, and I can phone from outside and the mobile phones are ringing!

The problem is… When a customer calls to the office and a worker that is phisically at the office tries to pass the call to the queue it never calls to the mobiles, it is impossible to reach the queue from internal extensions.

What can i do?

Thanks you very much in advance

Maybe something like this (I’ve not tried this on my system, this is just a suggestion):

  1. Go to Modules > Edit Config
  2. Expand Asterisk Custom Configuration Files and select extensions_custom.conf
  3. Add this to the text box:
    [from-internal-custom]
    exten => _1000X,1,Goto(ext-queues,${EXTEN},1)

Disclaimer: I’m of novice skill with Asterisk/FreePBX so, uh, yeah… make sure you have a backup or can easily undo any changes before trying anything!

If I’ve properly understand the way this works then you should be able to dial the queue number (for example 10001) from one of your internal phones. This assumes your phones allow that pattern to be dialled.


EDIT

It looks like you could also do this from within the GUI by going to Modules > Misc Applications and adding one there. The help text for the Feature Code input box is

The feature code/extension users can dial to access this application. This can also be modified on the Feature Codes page.

You can then select the queue that the code/extension should go to.

In re-reading your post, I may have misunderstood in that the ring group cannot by rung internally or it won’t ring external phones. Sorry not sure but this may still help. Dunno…

IMHO, the easiest way is to create a Custom Extension for each of your external phones and under the Advanced Tab -> Edit Extension add:

local/[email protected] with the pattern matching your number of course. If you have to dial 1 or 9 first etc change to 1NXXNXXXXXX etc.

Works great for me and works just like any extension, outbound only of course.

John

To simplify things, do you have the issue when one of your office workers calls one of the static agents directly? One possibility is that this could be a caller id issue, where your trunk doesn’t accept whatever callerid is sent for the failing calls. It would help to see an acli trace of a good call vs a bad one. Maybe even a sip packet capture, if your trunk is
over sip.

Instead of going to Misc Application on no answer, you want to config your virtual extensions with Find Me Follow Me to the external number. Enable confirm calls, then add the virt extensions to the queue. If the queue is configured to honor FMFM then the mobile numbers will be rung.

2 Likes

Thanks to everybody for your help!! I would like to start trying the @lgaetz tip!

So… I have created the virtual extensions (26002, 26004, 26005, 26006) with the FMFM with the external mobile numbers

And now I have create a queue 26000 with the FMFM in this way:

But it’s not working, neither from the outside nor from the inside :frowning:

HI

1.Please use internal extension in follow me to check if call fwding to internal ext.
2. Call to Mobile from your extension to check outbound routes are working fine. ( seems issue is here)

Thanks
Amardeep

Thanks for your answer @amardeeprana

The problem is already in the point 1. If I call to extension 26006 is not calling to the mobile phone… Maybe I don’t have all the needed options to achieve the idea of @lgaetz

Each virtual extension has these settings:

All settings are good at your end. I just wanted to if you are able to call these mobile numbers without follow me.

  1. Call to check without follow me. that will confirm outbound routes are fine. If these numbers are international . then use 011countrycodenumber#
  2. put your cell number to check.
  3. Check CDR reports if it Fwd calls to cell.

Hi again,

From an internal extension, we can phone that numbers directly: 666777999 (without prefix). The phone is ringing

I have tried to call directly to the virtual extension 26006 and the phone is not ringing

CDR report:

share screen with Zoom. I can check it.

I have just signed up on zoom

@amardeeprana you have a MP

Hi everyone,

I have just achieved to reach the desirate behavior

Virtual extensions:
FM - YES
Initial Time - 0
Ring Strategy - Ringall
Ring Time - 30
Follow-Me List - Number #
Confirm Call - NO
Mode - Fixed CID Values
Fix CID Value - OFFICE NUMBER

And then in the queue, add the static agents.

It’s working now!

Thanks everybody, and specially to @amardeeprana for your patience and helping

Great…

Did you guys way over complicate this? I just throw the cell numbers in the queue and set the queue to call as dialed. For ring groups you need to add a # to the end of the number.

There was issue with Caller ID setup in Follow me setting. It was resolved. .

Thank you

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.