Help - strange sip show peers results and a phone that won't register

I’m losing my hair here. At my age, that’s really NOT recommended.

I’ve just picked up a Panasonic KX-TGP550 T04 phone. Got it to replace my Siemens Gigaset S675IP. I love the features of the Siemens, but the user interface is killing me. I’ve dropped more calls trying to conference a 3rd party in than I care to count! I picked up the Panasonic to solve this.

The problem I am having is that I can’t get multiple lines to register at the same time. Actually, it’s a bit more specific. I can’t get 2 extensions on the same PBX to register at the same time. The phone works fine with multiple handsets and multiple lines as long as the voip lines are from different pbxes. As soon as I configure the extensions on the same server, only one will register at a time. The other is stuck at “registering”. Outgoing calls only work on one of the lines, and incoming calls ring for both extensions - but only behave as if they are on the one registered line.

If I do a “sip show peers” on the pbx, I can see both extensions, and they are both listed as registered as “OK”. Both list the same IP address and ports - just like my Seimens one did. So the server seems to think both extensions are registered, but the phone obviously doesn’t. Is this normal that 2 extensions will have the same IP address and port on a multi-line phone?

Network wise, the phone sits behind a Cisco e4200 which has had no configuration changes made since I unplugged the seimens S675IP. This e4200 sits behind another NAT router before it makes it out to the internet.

I haven’t done anything to configure any sort of specific NAT transversal - as I didn’t before. I’m willing to - but quite frankly - the Panasonic admin UI is about as intuitive as the daily use Seimens UI!


Try a different port on each “line”

Here’s what I’ve tried port wise:

  • set the port in the extension in FreePBX to 5061 (my understanding is this is ignored if the “host” parameter is “dynamic”

  • set the SIP source port in the phone for line 2 to 5061

  • done a hard reset of both router and phone

  • same behaviour

  • repeated with port 5070 for all places

  • same behaviour

Any other suggestions?


  • configured my second line with a outbound proxy service (

  • disconnected my entire office network, and plugged the phone directly into the ISP cable modem.

  • Both lines registered and could make and receive calls.

  • FreePBX sip show peers showed different IP and ports for each line

  • moved the phone back inside the outside router and reconnected the network

  • both phones registered and could make OUTGOING calls

  • only one phone (non-proxied one) could receive incoming calls

You just need a router that is more SIP friendly. I generally recommend a VPN to the off site FreePBX server.

That’s the kicker. My Siemens Gigaset S675IP is also a multi-line IP handset, and it works in the same place on the network without any extra configuration at all.

I’ve now tried setting the NAT setting on the PBX to No, and all that did is make it so I only have audio one way.

I think I might just give up.

When I plug the phone directly into the ISP connection - it works fine.

My wife saw me pulling out my hair and asked “Doesn’t anyone just have phones that you plug into the wall anymore?”

I don’t think you need separate ports for multiple lines, I’m fairly sure that most SIP phones will be using the “To” address to determine the correct line an incoming call is bound for. Certainly most incoming call issues I’ve seen are due to mismatched config on the phone and Asterisk.

Certainly some (a lot?) of SIP phones will reject incoming calls that are not addressed to a configured line even if its coming on the correct port.

Can you do a SIP trace and capture the INVITE messages sent from the Asterisk for each line? Hopefully can spot the difference between them and see why one works and the other doesn’t.