Help: set up SIP Trunk


(Mrt Tommaso Pbx) #1

Goodmorning everyone!
I’m here to ask if someone could try help my with the setting of a new SIP Trunk
at the moment i’m using a pot-line + gateway as a Trunk
now i have the need to change this and move to the VoIP

I’m low experienced, so i think the only thing i need to do is to set up new Trunk + in/Outbound routes
but i’ve no clue what to write there

important thing to know is that i have a router that give both internet and __VoIP service, i have the IP/SN/GW data

i tried read this: https://www.voip-info.org/asterisk-config-sipconf/ but i failed to understand, expecially because i’ve no user/password to insert… (on the current trunk i use this
host= gateway IP
type=peer
qualify=yes
disallow=all
allow=ulaw,alaw,gsm
but it doesnt work if i just put the ruter IP :confused: )

Please tell me whatever informatons you may need if you can help, thanls in advance for your precious time!


(Dave Burgess) #2

Please don’t use Chan-SIP for your trunks. It is deprecated and is the hard way now that the PJ-SIP trunk mechanisms work. The information you are trying to use is over a decade old and isn’t even close to being accurate anymore.

In your PJ-SIP trunk settings, set the authentication to “None” and add your provider address to the provider. You should be good to go.

Whatever Inbound Routes you are using are probably fine. Make sure you have an “any/any” Inbound Route that allows all incoming calls to be processed. You can tune this interface later.

Your Outbound Routes will have to include your new PJ-SIP Trunk in the list of trunks.

After that, you should be good to go.


(Mrt Tommaso Pbx) #3

Omg, your words kinda scary me, all my settings are done with the chan-SIP!
So i wi’ll have to change all the extensions to PJ-SIP and so on? :open_mouth:

You were pretty clear and helpfull man, i’m revy thankful!!

I’ll report back when i manage to make it works, thanks for your time!


(Mrt Tommaso Pbx) #5

i asked for help to the provider, they game me those infos
Trunk name: ITFTDxxxxxx
IP PBX Range : 87.241.X.X
Colt Signalling IP : 212.36.X.X.
Default Number : 39035xxxxx

i’ve obscured parts for obv reason (tbh i dont even know if its necessary to hide)

but i have no clue on which i should use and how to set things up


(Dave Burgess) #6

nothing to be scared about.

When you set up your extensions, define them as PJ-SIP extension. For systems that contact you, the port (5060/5160) is what defines which channel driver you are using. It’s not really that big a deal.

I’m guessing (because I don’t use your ITSP) that their address is 212.36.x.x. Put that in your trunk definition. Set up your IP address on the server as 87.241.x.x, which should be a single address. This probably doesn’t go in your trunk definition, it does belong in the Advanced Settings - SIP Settings.


(Mrt Tommaso Pbx) #7

i do feel stupid but… do you mean that i’ve to give to the laptop which run the PBX that static IP?


(Dave Burgess) #8

If I’m reading the instructions from your provider correctly, yeah.


(Mrt Tommaso Pbx) #9

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Mrt Tommaso Pbx) #10

Quick update, with the help of an italian freePBX technician, the pbx is working fine (there is a little problem with the IVR which sometimes act like if its muted, we are investigating)

asap it wil wok 100% of the time, i will update this comment to make a little guide and give some advices if someone will ever need to set up a VoIP trunk with a provider that doesnt give user / password, but just the IPs