HELP! Registering Extensions on CISCO SPA-8000 (tried a lot, still not registering)


I am a newbie with freepbx, I have my freepbx hosted by my provider, recently I set up my first trunk, outbound/inbound route and extension. Everything was pretty straight forward following the guides available

This is what I entered on my SPA-8000 line configuration:

Proxy and Registration
Proxy: freepbx.server.ip
Outbound Proxy: n/a

Subscriber Information:
Display Name: n/a
User ID: extension #
Password: extension secret
Use Auth ID: NO
Auth ID: n/a

After submitting, the line won’t register, I contacted my voip provider and his response was

“SPA do not send registration requests to the server…” (I don’t know what he means by that) :frowning:

Please, could someone be so kind as to help me with the configuration of my first extension?, thanks in advance! :slight_smile:


It could be the very common problem with UDP keepalive or something around it.
To get aquainted with it take a look over here for example:

To solve this issue temporarily, just change SIP port of unregistered line. For example 5061 to 5063. It should help till the next network failure somewhere around your router … :slight_smile:

If your voip provider supports TCP, change “SIP Transport:” field to TCP and this will solve your registration issues permanently

Best regards,

Hi Kirill,

Thank you very much for helping me, the line simply doesn’t register, I have 7 other lines on the same ATA, all register fine with my provider’s SIP server.

The only “major” change I made was updating SIP Port from factory setting to 5060, now, I’m gonna try updating that one line to 5061 or 5063 and see.

However, my one and only freepbx extension in the ATA doesn’t register at all, no timeouts, it’s just won’t connect. :frowning: