FreePBX | Register | Issues | Wiki | Portal | Support

[HELP] New Let's Encrypt Certificate FreePBX 14.0 for WebRTC


(Long Zonal) #1

I trying generate 1 certificate follow tutorial, but can not generate, please help me why!


(Jared Busch) #2

Your answer is likely here.


(Long Zonal) #3

i don’t know why it not working for me.
This is my hostname
and i generate like this
and result:


please tell me why :frowning:


#4

To get a certificate from LetsEncrypt, you can’t just make up a name – it has to be a real domain (or subdomain) that is yours.

If you own a registered domain name, for example doanvulong.com, you could use mypbx.doanvulong.com for the Hostname of your PBX. You would go to the DNS section of your domain registrar’s site and add an A record that points mypbx.doanvulong.com to 113.161.88.148 . You also have to configure your firewall so a request from outside your network for 113.161.88.148 TCP port 80 will reach your PBX.

If you don’t have a registered domain name, you can get a free subdomain from a dynamic DNS provider such as https://changeip.com . For example, you might get pbx13579.changeip.org , which you would use as your Hostname.

Once you have set this up, confirm that the name can be accessed from outside your network. For example, turn off Wi-Fi on your mobile phone (so it uses the carrier’s mobile data network) and try to access for example mypbx.doanvulong.com . If you don’t see the FreePBX page, find out what is wrong (domain doesn’t resolve, resolves to wrong IP address, firewall is blocking access, etc.)

Finally, once you get this working, try obtaining the certificate again.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.