HELP! Just did the latest update, FreePBX reports "Tampered File"

I’m running:
Current PBX Version:
Current System Version:12.7.4-1803-1.sng7
Total Module Count:118

I just ran module update. It finished and I updated the configuration as usual. Now, Dashboard displays this:

Worse, I’ve tried doing restores from recent backups and it reports “error uploading file.”

What do I do?

fwconsole ma refreshsignatures

That did it! The problem was with framework. Thanks so much!

1 Like

I just had the same problem. I found that fix via search and it worked.

Just finished updating a version 14 machine, same issue.
Seems like something is wrong…

I just had this too - FreePBX Framework Upgrade crashed module admin apparently when it tried to retrieve GPG signatures and then I had to install again, got the tampered file warning, and re-downloaded and installed it, then it was okay. I think something is borked with signature retrieval in the upgrade process.

Nope. That’s not the issue. Upgrade framework and all will be resolved.

I had the same issue today. I re-downloaded and forced a reinstall and it cleared up the problem. Seems to me that if we all had the same issue we can’t all be doing something wrong. Maybe something could be wrong with somewhere in the update process?

As Andrew just said update framework. Issue is fixed in latest framework.

fwconsole ma --edge upgrade framework

I just had same problem with latest update/s, and showing 21 tampered files.
fwconsole ma refreshsignatures appears to have resolved all issues.
An update to framework was included in this refreshing process.