Help installing Asterisk, FreePBX, Zaptel Drivers on CentOS 5.4

Hi - I’m brand new to Linux, Asterisk, and FreePBX. I’ve been trying for over week now to get a freePBX box running. I’ve tried everything (except what works obviously).

I now have a box with a fresh install of CentOS 5.4. It has a Digium TDM2400P analog card with a single 4 channel FXO module installed. I currently have 2 POTS lines connected to the card.

I’ve tried the Asterisk NOW installation but only to have errors. I’ve tried to load CentOS then Asterisk, then FreePBX using some instructions found here in the forum without avail.

here are the instructions I tried:

I’ve now found a script that supposidly installs Asterisk, Zaptel Drivers, and FreePBX but I’m not even sure how to run the script or what changes to make to the script to accommodate my variables such ass passwords, ip address of machine etc… …and then I have no clue on how to even configure the zaptel device.

here’s the install script:

So now I have this box with CentOS and the Digium card in it? What’s the next step.

Help would really be appreciated. I’m totally lost here and would like to get this PBX system up so that we can use IP/Soft phones to dial out on our POTS lines.

Thank You in advance!


This is just my personal opinion, but I would tend to recommend that you try either Elastix or PBX in a Flash (both of which include FreePBX and Asterisk). I don’t have any real preference but can tell you this. PBX in a Flash seems to have a larger, more active community so you may be able to get help there easier - the downside is that if you use their upgrade scripts, they may overwrite some changes you’ve made in your system - PiaF just takes a bit too much control over your system for my taste, although that’s just me and a lot of people might think that an advantage, since it keeps you from having a lot of issues you might otherwise have. Elastix comes with more add-on software but they do not provide a clear upgrade path (especially for the Asterisk components), and frankly it seems like whatever enthusiasm there might have been for that project is slowly shrinking. They really do not seem to have as large a community of users (on their forums) as PiaF (at least not on the English-speaking side, however if you speak Spanish that may be another matter entirely - I don’t, so can’t comment on that).

Either of those might be a better choice than AsteriskNOW, and either would probably help you avoid most of the issues you are having now… but again, that’s just my personal opinion.

JD, i have the same error now with CentOS 5.8, did you finally find the solution to this problem???

Thanks for share it with me.



Check this tutorial

Do you have any questions??? Post it!!!