HELP - Incoming Calling Issues

Hello All,

I have installed a new instance of IncrediblePBX 2027-U in the cloud. I am having issues with all of my DID providers. Here is my problem:

  1. I have 3 DID providers
  2. Their respective Trunks (chan_sip) are registered with my server.
  3. Inbound routes have been created for the DID.
  4. Inbound routes are routed to their respective extensions.
  5. Call DID and rings NO ANSWER.
  6. CDR shows call presented to Server, with a no answer termination.

I am using Incredible2027-U, Asterisk 20, FreePBX 16. I have completed a Module Update for the system.

Anyone have any ideas as to what is causing the system not to answer calls when they are presented to the server?

Thank you in advance to anyone who can help me out.


Andrew Stock

Is chan_sip even an option in Asterisk 20?

Does the DID field of the CDR show the expected value, exactly matching your Inbound Route?
Does the Destination field of the CDR show the expected extension number?
If you call the extension from another local extension, does it ring properly?
On a failing inbound call, can you answer the extension when it should be ringing?
If the system were working properly but the call was unanswered, should it have gone to voicemail? Does it?

It’s the last LTS to have chan_sip. As of right now, chan_sip and other modules that are being removed in v21 are no longer in the master code branch for Asterisk.

@AndrewStock IncrediblePBX issues are better handled at the IncrediblePBX forums at The VoIP-info Forum . While IncrediblePBX uses FreePBX, there are many customizations that people on the FreePBX forums may not be familiar with.

@dobrosavljevic IncrediblePBX 2027-U has chan_sip enabled in the compile of Asterisk 20 and uses non-commercial open source FreePBX-16 with chan_sip enabled. Chan_sip is not the issue here.

I would recommend that the OP log into the FreePBX CLI with asterisk -rvvvvvvv and monitor when an incoming call is processed. Make sure that the DID number presented to the PBX is the same number you have defined in your incoming route. If you don’t see any traffic when you call the DID number, either the call is going to the old server or you have not whitelisted the incoming IP address. You need to provide more information on what recording you hear when you call the DID.

The IncrediblePBX firewall has built in IP ranges for many, but not all, VOIP providers. You haven’t said who your DID providers are. If they are not in the built-in whitelist, you need to add them. General instructions for installing IncrediblePBX-2027-U are in this article: Happy New Year: It’s Incredible PBX 2027 for Ubuntu 22.04 – Nerd Vittles You have not mentioned if your are using the pre-built Crown Cloud instance or some other cloud provider but that may be relevant to setup.

Also, you likely need to disable your trunks on the old system in order for the calls to route to the cloud instance; especially if your are using register on the trunk to your providers.

After you get your incoming calls working, it is advisable to convert your trunks to PJSIP as the future releases of Asterisk will require some manipulation to even include chan_sip. There is plenty of information on setting up PJSIP trunks in the forums at The VoIP-info Forum .

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.