HELP! Function CURL not registered / Caller ID Superfecta

I am having a problem with Caller ID Superfecta. I looked in the logs an it looks like I am getting this error:

pbx.c: Function CURL not registered

I installed Curl Devil and still no luck.

I read another post saying to recompile asterisk, but I am afraid of doing that since this is a production sever. I don’t want to delete any settings. Knowing my luck it will delete everything and not even work.

If anyone has any suggestions at all please let me know. I really want to get Caller ID look up working.

Ubuntu Jauanty

Looks like no one is going to help me, so I guess I need to search for Caller ID alternatives that may not use the Curl method.

Any suggestions?

Ok I solved my own problem. To get Curl working on Ubuntu Jaunty you need to do the following:

sudo apt-get install libcurl4-openssl-dev

cd /your asterisk source directory

make install
make config

This process got the Curl function working for me and now Callerid Superfecta is looking up the callerid and working properly.


Same problem, but … i have asterisknow … so i cannot find asterisk source.

what to do? :wink:

you may want to report the missing function on the digium bug tracker for asterisknow and see if they will address it and update the asterisk rpm.

Install the asterisk-curl program. If you are running asterisk 1.6 do a “yum install asterisk16-curl”. then restart asterisk and assuming you do not have any other problems Caller id Superfecta should start working.

The above fixed it for me on *Now 1.7 running *1.6 and freepbx 2.0.8

Hope this helps.


You have to tell it to install the curl code:

yum install curl-devel

and then when you configure asterisk, you have to make sure to include the following option to the configure command line:

./configure -with-curl

The rest is the same.

Hope this helps others with the same issue.