Help!FreePBX and Cisco 7940

Hello!I am a newbie and i want your help!
I have two cisco phones 7940. The first one is on the same subnet with the freepbx server( the second one is on the second ethernet interface of a mikrotik router( The 7940 phone which is in the same subnet registers just fine but the other one on the other subnet does not. If i install in its place a softphone or a linksys pap2t registers fine. I have tested all the possible combinations of nat(in the freepbx and in the phone but nothing).
Has anybody any idea??? I am working in it already a week and nothing!

You should not need NAT on a connected network.

Make sure the network is listed under localnet’s in SIP settings module.

On the Microtik make sure the interface on the interface is in route mode, not NAT.

Also I deleted your duplicate post. 1 Thread per subject please.

Thanks for your reply!
But because i am newbie what do you mean by saying "Make sure the network is listed under localnet’s in SIP settings module."
I have nat–>route and ip configuration–>public ip.
Is that what you are talking about?Where can i find the localnets?
The router is in route mode.I know that it shouldn’t be a nat problem but i can’t find a solution!
I am sorry i don’t know much and i appreciate your help!
Thank you in advance!

You need to read the Asterisk documentation to understand how NAT processing works.

However for your implementation you only need two things:

1 - Your router must have a rule to allow traffic to pass between the two networks without NAT

2 - You need to add the localnet to the local networks section in SIP settings. I am not sure how you missed it, the field is right below the one you described. Just add the second network so that Asterisk excludes that network from NAT processing.

Thank you very very much for your help.The problem solved!I hadn’t included the other network in the nat settings!!!Thank you very much again!!!