Help connecting handsets to remote FreePBX server


(Gavin Smith) #1

Hoping someone might be able to give me a dummies walkthrough on setting up remote phones using the End Point Manager
I have been trying to connect a Yealink T46G to a remote FreePBX install hosted on a cloud server.

I cannot get the phones to auto provision using EPM. I have tried disconnecting the server firewall and also the FreePBX responsive firewall and still nothing.! I don’t know where I am going wrong


(Garry Winer) #2

Your issue may be an external firewall or the FreePBX firewall.

If there is an external firewall make sure all the ports are open to the PBX. As for the FreePBX firewall you need to add the public IP address of the other side where the phone is to the firewall as either trusted excluded or a local network. If that wont work you could also try under the responsive firewall tab to enable SIP Protocol (pjsip).


(Gavin Smith) #3

I have disabled the firewall completely and still no luck. I can get everything to connect if I manually setup the account in the phone’s GUI but I cannot for the life of me get the EPM to auto provision.


(Jared Busch) #4

It will never auto provision a new phone remotely because it can only tell registered phones to reboot or reload config. It does that with a SIP message, thus the need to be registered.

If you want a new phone to hit your system, you have to setup a DHCP option to tell the newly booted phone where your PBX is.

With Yealink phones, I always set the DHCP to use authenticated HTTP (not HTTPS) as some models cannot work with the LE cert created by FreePBX 14+. I use a secondary template to change it to HTTPS provisioning for the models that support that.

Here is how that looks in my Ubiquiti EdgeRouter

set service dhcp-server shared-network-name LAN subnet 10.254.103.0/24 tftp-server-name 'http://1234567890:[email protected]:84'

I have posted samples for Windows DHCP Server on here before that you can search for.


(Lorne Gaetz) #5

hijacking thread …

With the recent changes in SNG7 to the LE root cert, are affected Yealinks able to do https now?


(Jared Busch) #6

Have not tested yet.


(Gavin Smith) #7

No.

Thanks everyone. I ended up paying for Sangoma support - Not cheap and had to buy a minimum 2 hour block and only took the support tech 20 minutes to fix.

So Jared, it turns out the Yealink can auto provision (not sure how he got it working but it does work) but you’re correct that they don’t support HTTPS - or at least not the Yealink T46G I’ve got.