FreePBX | Register | Issues | Wiki | Portal | Support

Hearing myself (echo) while remote party is on speaker phone (all SIP)

freepbx
Tags: #<Tag:0x00007f749551a9f8>

(Benoit Lambert) #1

Hey,

One of our clients is experiencing echo issues while the remote party is on speaker phone.
The person on the phone with a remote speaker phone user hears their own voice in the background.

I already have a Sangoma support ticket opened for this issue but so far nothing has worked.

Here is some info on the environment:

  • The environment is all SIP (no analog) and they’re using S500’s.
  • Some phones are in an office with an IPsec VPN and others are simply using the Internet to register (home offices)
  • This was always a problem since the PBX was configured
  • Version is FreePBX 14 with Asterisk 13 (system and modules are now up to date after initial round of troubleshooting - problem persisted)

Here is what we have tried so far (not necessarily in this order):

  1. Power cycled phones and PBX
  2. Upgraded phones to latest firmware
  3. Upgraded system and modules to latest version
  4. Use G722 Wideband (used to be ulaw)
  5. Adjusted the all three send volume settings in EPM to a value of 4 (this equates to -2db)
  6. Configured EPM template to override local phone config

All of the above failed so I tried to register different phones to the clients PBX to try to get different results.

I registered two Yealinks to the system and ran some tests with them (sound quality on Yealink’s are so much better IMO):

  • S500 provisioned on client PBX and Yealink provisioned on client PBX -> no echo
  • Yealink provisioned on client PBX and another Yealink provisioned on client PBX -> no echo
  • S500 on a different FreePBX and another S500 on the same PBX -> no echo (this is our internal FreePBX system, not the client)

I’m still waiting for Sangoma support to reply, its been 10 days since I heard from them, not sure what next step they will recommend.

Thanks in advanced to anyone who takes the time to answer.


(Jared Busch) #2

This has everything to do with the remote party’s speaker phone settings and environment.

Yealink phones have a setting to adjust speaker phone mic pickup. I would not be surprised if something similar exists for Sangom phones.

The hard part is different environments cause different amounts of echo.

My boss’s phone continually had echo until I got the mic pickup right. He never uses his phone except on speaker phone…

My desk phone never causes the issue, with default settings.


(Benoit Lambert) #3

The S500’s do have a similar setting: the 3 “Send Volume” settings in the EPM template. I have configured all three to the lowest setting of 6 which equates to -6db. It basically decreases the send volume from handset, headset and hands free (speaker). I’m still getting the issue after making this change, the echo is just quieter like the entire call.

Its like there’s something fundamentally wrong with the phone and PBX combination.
Our client has 4 remote employees and sometimes they go into the office. The issue occurs at each location, it even occurs at my local office when I provision my test phone on their system. So its not a physical environment problem.

We use the same PBX and phones internally and we can’t replicate this problem on our system.

Thanks for the quick reply! I appreciate it.


(Greg) #4

It’s still an issue with the far-end phone. If the phone itself doesn’t have echo cancellation (in other words, cancelling the sound that it itself is putting out) then you will get echo.

See if there is an echo cancel option on the phone settings itself, or try a different model phone. We have Yealink T46G’s, and have never had this issue.


(United States) #5

I have the same problem. We recently upgraded from older Cisco phones to the Sangoma S500. We find that it is almost unusable at times when it is Sangoma s500 to another s500 on speakerphone. We have tried changing the db to -6 and adjusting other parameters and only using g711. Nothing seems to fix it. On the latest version of the s500 firmware.


(Benoit Lambert) #6

Glad to hear its not only us. I have a ticket open with Sangoma and they’re scratching their heads. Last update I got from them is they handed off the issue to their “phone division”, whatever that means.

I’ll keep this thread updated with my progress.


(John Estep) #7

I have also having this issue lately and it is talking between to S500’s so it is not an external problem. 2 People, 2 different rooms and after a while you start getting the echo feedback, Hopefully Sangoma can figure out the issue.


(Benoit Lambert) #8

Hey jestep, glad to hear its not just cmslaght1 and I experiencing this problem.

As stated above, my ticket for this issue was escalated to Sangoma’s phone division.
I have asked my support rep what that meant and he stated it was the department that takes care of firmware releases.

I hope their actively looking into it…


(United States) #9

The released a new firmware the other day but the release notes dont say anything about fixing an echo problem. I have IMG 2.0.4.37 on my phone and did not seem to have the problem. In all fairness, my phone was disconnected until today. I downgraded another phone to this older version to see if it helps at all. If anyone tries the new firmware, let me know how it goes.


(Tony Lewis) #10

.37 is really old firmware. I suggest to everyone here to update firmware and let us know.


(United States) #11

So we did downgrade to 2.0.4.37 and the echo issue went away. I don’t believe that we made any other changes. Ill have my client test a phone that has not been downgraded and see what we get.


(United States) #12

Confirmed that when I tested two phones with the V2.0.4.57, the echo is still present so no changes on the pbx have occurred, Just downgrading to the .37 resolved the echo issue. I don’t know when the echo was introduced so for now, I will leave at least the one phone downgraded. Next is to upgrade a different phone to the firmware released a few days ago.


(Benoit Lambert) #13

Thanks for the testing cmslaght1!

I will test a firmware downgrade to 2.0.4.37 with my Sangoma engineer.

Will reply to the thread when I have results.


(United States) #14

Ok. Here is were I left off. All test are done calling Sangoma S500 to Sangoma S500 both on speaker on a Freepbx 13.0.195.26 will all the patches installed.

With firmware 2.0.4.57 —> echo to a critical level within a couple of minutes.
With (new) firmware 2.0.4.59 —> echo to a critical level within a couple of minutes.
Downgrade to 2.0.3.37 —> So far so good. Customer had many conference calls last two days without issue.

I downgraded all my phone except one. For some reason one of my phone would “Upgrade Fail” and then reboot. I got it back on .59 and ran out of time.

I agree with Tony that this firmware is old and should not be used but I don’t have the time to figure out were the echo problem was introduced. The only reason I went to this particular version was because my personal deskphone was on this version and did not have the problem. My customer was pretty upset with the echo so this will resolve my issue until some firmware update to resolve the issue comes out.


(Chris Dolese) #15

for anyone experiencing this issue please open a phone support ticket and note this post and my name - we have a beta firmware in hand that we believe addresses the issue


(United States) #16

Did anyone get the test firmware? I have not had a chance to open a ticket up and request it.


(Lorne Gaetz) #17

@dragonparoxysm and I have tested firmware ver. 61 with success. Watch this page for an auto update when it’s published:
https://wiki.freepbx.org/display/PHON/Phone+Firmware+Release+Notes

Alternatively, open a phone support ticket and request a pre-publication version.


(Benoit Lambert) #18

Apologies for not replying, Lorne and I did test with a beta release and it did solve the issue.
I’m waiting for the official release of 2.0.4.61 before pushing it to my clients phones.


(Benoit Lambert) #19

Firmware 2.0.4.62 fixed the issue.


(system) closed #20

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.