Having trouble with path in local server backup

I created a new asterisk/FreePBX system from scratch using the distro (FreePBX-Distro-NET 32 bit I created a new local backup server with the path of a NFS-mounted file system, and created a new backup job using the “Full Backup” template and dragged the newly-created local backup server to the “Storage Servers” list.

When I ran the backup using the “Run now” button, the backup completed successfully but the backup file was placed in /var/spool/asterisk/backup/ instead of the path in my new local server entry.

Just out of curiosity, I removed my new local server entry from the list and dragged over the “Legacy Backup” server and tried again. The backup file still went into /var/spool/asterisk/backup/ instead of the legacy location. I even tried creating a local server entry pointing to /tmp (in case there was a permissions problem with the other path) but the backup file still went to /var/spool/asterisk/backup/.

I originally submitted this as a bug, but it was closed as “worksforme” so I assume it must be something I’m doing wrong or something unique to my installation. I would appreciate any help in resolving this issue.



I am running into this now. Have you found a fix for this issue or is it just a problem with the “Run Now” button? I tried making it go to /tmp but it continues to put it in the default location. I’m going to let it go tonight and see if it is a problem with running it manually.


I have the same problem too.
I’m investigating, but this is clearly not a permission issue.
Guess that the module backup does not use the path when the storage is set as “local” ?


fixed: http://www.freepbx.org/trac/ticket/5682