Having Issues Setting Up Dahdi Trunks

dahdi
Tags: #<Tag:0x00007f70285c4f28>

(Heynow) #21

Ok, so I was able to get it working but I am not entirely sure what the culprit was.

First, I checked and triple checked my Dahdi DID’s, my inbound routes, my outbound routes, extension routing, and trunks to confirm that I SHOULD be able to dial out and in. There was nothing explicitly stopping me from being able to dial out from the desired extensions. I read all of the respective wiki’s to make sure I set everything properly.
I followed this with disabling the Dahdi module from the web GUI and rebooting the server. I then ran wancfg_dahdi and re-configured the card. This was followed by another reboot. After which, I re-enabled the dahdi module from the web GUI and rebooted the server again. After the final reboot, my config files we’re looking different than what I had initially posted. I went into chan_dahdi.conf and made sure that the specified channels had the context=from-analog set. After an fwconsole restart my configs stuck and I was able to make calls out and in. Thank you all very much for your help. I have a further question, and I will open another thread if need be, will my changes be persistent? If not, how do I make them persistent?


#22

Providing you don’t touch anything anymore dahdi will stay dahdi.


(Heynow) #23

Got it, thanks! I’ll stay away then.