Having issue with IVR and Contact List Speed Dials

Greetings all,

I had an instance where a customer wanted to create a Speed Dial soft button on their phone. They didnt want to have pages of soft keys, nor did they want to have to dial *10xxx.

What they ended up having me do was to create a “speed dial ivr”. Now when they hit the “speed dial” soft button, they can immediately punch in a two digit number and it rings (or is supposed to) the desired phone number.

The problem is that this doesn’t work. I have configured each button for the IVR and selected Contact List Speed Dial, and the appropriate speed dial. When it tries to dial, it complains about an invalid extension.

I poked aorund in the extensions_additional.conf file, and was able to determine the issue is that the IVR is reading ‘10’ lets say, but its trying to speed dial ‘10’, not ‘*1010’. I was able to circumvent the issue by creating a ext-contactmanager-sd-custom section, creating a line for each of the extensions as follows :

exten => 10,1,Goto(app-contactmanager-sd,*10${EXTEN},1)

Now it works as expected. I believe this is probably a bug?

I am running PBXact

Any comments or suggestions?


Why not just make a prefix key on the endpoints. It will prepopulate the *10, they dial 10, then the device dials.

So this could be divided into two parts I suppose.

The first part, using speed dial keys on the endpoints work fine. I was creating an IVR to facilitate a 1 button press and dial the two digit extension to get a speed dial. I can set this up to dial anything else, and it works. I think this might be a bug - why FreePBX is sending “10” to the speed dial context when it should be *1010 i dont know. Thats where I added that custom dial plan and it resolved it. Thats why I am asking if its a bug.

The second part, using a prefix key on the endpoint sounds like what I was trying to accomplish. The issue is I can’t find how to setup a prefix key button. I don’t have a prefix option on the endpoint manager template for the Sangoma S705 phone that I can see.

Thoughts… comments?


Can’t easily test right now, but I believe setting a BLF/Speeddial button with *10+ will do what you want. the + character says wait for more digits to follow.

Thanks @lgaetz . I’ll give that a try.

If that works I guess it is all a moot point, but anyone that cares to try creating an IVR using some Contact Manager Speed Dials as the options, see if you can dial it okay. I could not, without creating some custom dialplan entries. The point is, it should have worked… right?

Looks like you’ve found a bug. Can you open a ticket pls at:
and share the link here in this thread.

@lgaetz :

Here is the link : https://issues.freepbx.org/browse/FREEPBX-22071


1 Like

Yealink and Fanvil phones have a “Prefix” button type.

That is what the prefix key type is for. Press prefix key that does the *10 then press the speeddial ext#

Then phone should then dial after the appropriate timeout, or immediately if you make a dial string to match.

Here is an example from a Fanvil phone with the prefix key doing a * so the user can send calls direct to voicemail.
In this case a 3 step process.

  1. Press Transfer
  2. Press “To VM”
  3. Press BLF

or 4 step.

  1. Press Transfer
  2. Press “To VM”
  3. Dial extension
  4. press Transfer

@sorvani :

I looked around for what you are referring to. The phones I am working on are S705’s. These are the only options I have in the Endpoint Manager?


I haven’t had a chance yet but plan to try @lgaetz suggestion about a speeddial/blf key for *10+

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.