Have couple Voicemail Box not working

I have few Voicemail Box that are not working, it tells me the extension is unavailable. Even though both ext and Phone are setup. I even started from scratch on both the extension and phone settings. But I still keep on Getting “Device Is fixed and cannot be logged into” I looked on here about *11/*12 but that did not work.

Here is log of a working ext
[2013-02-01 15:52:18] VERBOSE[2518] app_read.c: – Accepting a maximum of 1 digits.
[2013-02-01 15:52:18] VERBOSE[2518] file.c: – <SIP/128-00001497> Playing ‘/var/spool/asterisk/voicemail/default/141/unavail.slin’ (language ‘en’)
[2013-02-01 15:52:20] VERBOSE[2518] app_read.c: – User disconnected
[2013-02-01 15:52:20] VERBOSE[2518] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/128-00001497”, “”) in new stack
[2013-02-01 15:52:20] VERBOSE[2518] pbx.c: == Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/128-00001497’

Here is extension that is not working

[2013-02-01 15:52:50] VERBOSE[3022] netsock2.c: == Using SIP RTP TOS bits 184
[2013-02-01 15:52:50] VERBOSE[3022] netsock2.c: == Using SIP RTP CoS mark 5
[2013-02-01 15:52:50] VERBOSE[2528] pbx.c: – Executing [*[email protected]:1] Macro(“SIP/128-00001498”, “user-logon,2,”) in new stack
[2013-02-01 15:52:50] VERBOSE[2528] pbx.c: – Executing [[email protected]:1] Set(“SIP/128-00001498”, “DEVICETYPE=fixed”) in new stack
[2013-02-01 15:52:50] VERBOSE[2528] pbx.c: – Executing [[email protected]:2] Answer(“SIP/128-00001498”, “”) in new stack
[2013-02-01 15:52:50] VERBOSE[2528] pbx.c: – Executing [[email protected]:3] Wait(“SIP/128-00001498”, “1”) in new stack
[2013-02-01 15:52:51] VERBOSE[2528] pbx.c: – Executing [[email protected]:4] GotoIf(“SIP/128-00001498”, “1?s-FIXED,1”) in new stack
[2013-02-01 15:52:51] VERBOSE[2528] pbx.c: – Goto (macro-user-logon,s-FIXED,1)
[2013-02-01 15:52:51] VERBOSE[2528] pbx.c: – Executing [[email protected]:1] NoOp(“SIP/128-00001498”, “Device is FIXED and cannot be logged into”) in new stack
[2013-02-01 15:52:51] VERBOSE[2528] pbx.c: – Executing [[email protected]:2] Playback(“SIP/128-00001498”, “ha/phone”) in new stack
[2013-02-01 15:52:51] VERBOSE[2528] file.c: – <SIP/128-00001498> Playing ‘ha/phone.ulaw’ (language ‘en’)
[2013-02-01 15:52:52] VERBOSE[2528] pbx.c: – Executing [[email protected]:3] SayDigits(“SIP/128-00001498”, “128”) in new stack
[2013-02-01 15:52:52] VERBOSE[2528] file.c: – <SIP/128-00001498> Playing ‘digits/1.ulaw’ (language ‘en’)
[2013-02-01 15:52:52] VERBOSE[2528] file.c: – <SIP/128-00001498> Playing ‘digits/2.ulaw’ (language ‘en’)
[2013-02-01 15:52:53] VERBOSE[2528] file.c: – <SIP/128-00001498> Playing ‘digits/8.ulaw’ (language ‘en’)
[2013-02-01 15:52:53] VERBOSE[2528] pbx.c: – Executing [[email protected]:4] Playback(“SIP/128-00001498”, “is-curntly-unavail&vm-goodbye”) in new stack
[2013-02-01 15:52:53] VERBOSE[2528] file.c: – <SIP/128-00001498> Playing ‘is-curntly-unavail.ulaw’ (language ‘en’)
[2013-02-01 15:52:54] VERBOSE[2528] app_macro.c: == Spawn extension (macro-user-logon, s-FIXED, 4) exited non-zero on ‘SIP/128-00001498’ in macro ‘user-logon’
[2013-02-01 15:52:54] VERBOSE[2528] pbx.c: == Spawn extension (from-internal, *112, 1) exited non-zero on ‘SIP/128-00001498’
[2013-02-01 15:52:54] VERBOSE[2528] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/128-00001498”, “”) in new stack
[2013-02-01 15:52:54] VERBOSE[2528] pbx.c: == Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/128-00001498’

Any input is appreciated.

no one has had this issue :(.

I once had this issue and had to configure the VM context to something different… then I started getting more extensions that needed the change… I ended up changing all VM contexts to this (something different) and forgot about it.
When I upgraded, it went away (this one was with @home quite a while back)

I’m not sure this is what you have though…

What voice mail boxes are you referring to?

You’re dialling *112 hoping to get to the mailbox of SIP/128? but the system is dialling 128… Totally unsure of what I’m seeing.

I am more and more convinced that for some reason your phones are filtering out “28”.

Go into a phone in the “Dial Plan” section, set the “Dial Plan” field to “[x*].” (without the quotes).
Then see if that phone can dial 28. Also, make a note of what the dial plan is before you make the change and let me know.

If you want to call me via phone, feel free to do so.

BF

You responded to “Strange Problem” - this fellow here has a problem that I haven’t figured out yet (the problem not the answer).

IF you could help me out that would cool. TO explain what is going on is. When i dial from anybodies phones in the office and try to dial *112,*115,*110 and *113 VM box. I get 128 is currently unavailable. I have already tried paid tech support but they did not solve anything. I am stuck so any help would be nice.

*11 is supposed to be “login”. I don’t know how you’re getting 128 but try changing the * prefix (if that’s easy) in General settings / Direct Dial Voicemail Prefix. Sorry I missed that in the log.

  • followed by the extension number is used when transfering a call directly to users voice mail. You can’t dial *11 to access a users voice mail. *11 is used to log an agent in. To access voice mail for a user dial *98 or *97, I forget which to get to the voice mail systmem and then enter the users extension and password.