Hash/pound key on inbound calls


I have a problem with the hash/pound key on inbound calls. When a customer arrives at our office they put a code into a keypad which calls our office, we answer the call and press # which will then lower the barrier to let people in (by virtue of the correct DTMF tone being played down the phone).
Since moving to Asterisk this has stopped working. Pressing the # key on an inbound call now transfers the call rather than playing the DTMF tone. Since all of the phones have a transfer button on them I don’t think I should need the # feature code.
I have disabled the feature codes for attended and blind transfer and the dial options are just “r” but the transfer feature code is still set to # somehow.
I have trawled through all of the many conf files and can’t see where this may be set. I have also tried adding a feature code for # which would divert to VM but still it wants to transfer the call.
I am running Asterisk 1.4.29 and FreePBX 2.8.0rc1. The configuration is pretty much out-of-the-box with just trunks and extension added (no real customisation).
The Asterisk log files don’t show anything for when the # key is pressed, just the call arriving, being sent to the hunt group and being answered.
Apologies if this is something glaringly obvious but I’ve exhausted all the possible places I can think to look.
Any assistance would be extremely gratefully received.

Many thanks,


Try editing the /etc/asterisk/features_featuremap_custom.conf by adding the following line:

blindxfer => #1

Then reload asterisk:

asterisk -rx “reload”.

See if that solves your problem.


Bill, thanks for your quick response.
Unfortunately, that hasn’t made a difference.
I did try setting that to a value not including a # also but still no joy.
Something I did wonder was whether I could create a new feature code of # which just played the appropriate tone. Does that seem feasible? It seems like the wrong way to go about it but if it works it works.



You did edit the right file? If you edit anything other than the “custom” file it will be overwritten at every reload.


I did indeed.



Hi Dan

Did you get to the bottom of this… I am having the same problem… cant work out where asterisk is picking up the hash.

I have a specific problem with cisco meeting place. I have to enter the meeting number followed by the hash key… soon as I press it asterisk tries a call transfer…

The call originates as inbound… I have avaya softphone forward from work.

Make me want to bite someone :wink: