Hangup doesn't work

i have a problem with some installation of Freepbx in different version.
It isn’t a big problem and my customers haven’t realized , but now i want to solve that.
When i make a call inbound , and there is an answer all is ok.
Instead if i make an inbound call , usually for test and i hangup from smartphone before the answer , phone in PBX ring than stop and restart to ring for at least tree times (while my phone have already hangup) and i see my smarphone number on phone display of PBX.
thanks :slight_smile:

What type of trunk are you using?

trunk to grandstream gxw 4104 config
type=friend
secret=XXXXXXX
qualify=yes
port=5060
host=192.168.1.211
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw

i will try from other clients with trunk to patton 4120 isdn and to provider voip , but i am pretty sure the problem occurs with patton too

ops I haven’t deleted the secret but it’s all local anyway :slightly_smiling_face:

done

Analog trunks need ‘disconnect supervision’ provided and provisioned for or you could add

busydetect=yes
busycount=3

to your trunk.

Do your Italian phone lines come ulaw or alaw?

codec enable in my pbx are these
g729
gsm
ilbc
alaw
ulaw
g726
but i don’t know type of codec used by PSTN provider in inbound call.
there is a way to know ?

I imagine all PSTN lines in Italy are alaw, adjust your trunk ‘allow’ for best ‘de-emphasis’

Your provider can tell you what form of disconnect signal the are sending (or not sending)

thanks :ok_hand:

Hello , finally i found a solution.
My background is from networking and phone system is not my work :slight_smile:
I solved problem with help of my reseller tha find me fxo settings on Grandstream GXW4104.
For Italy i apply this settings :

thanks