HA Status Down other node UNKNOWN

Hi,
My freepbx HA status page is showing as down and other node is unknown, however if i put the either server into standby via CLI it fail overs successfully

in the /var/log/httpd/error_log im getting this message

PHP Fatal error: Class ‘FreePBX’ not found in /drbd/asterisk/lib/agi-bin/LoadLicenseIfExists.php on line 45

any ideas what his means?

Hello.
I have the same problem!!!

This is a problem in System Admin. It’s -only- a display issue, and the machines are NOT down.

If you do an online update, you’ll see that Sysadmin 12.0.27.1 is the only version available, if you roll back to that, everything will be fine.

I would have released a fix, but I’m actually in the middle of travelling to Toronto, and I have some apprehension about releasing a module and then jumping on a plane for 14 hours :sunglasses:

–Rob

I’m experiencing the same issues with a newer version of SysAdmin 12.0.28.2

Please advise.

What happens with 12.0.28.4 that was published this morning?

That seems to resolve the issue with the HA Web UI.

When i put freepbx-b into standby i get this error:

Failed actions:
httpd_service_start_0 on freepbx-a ‘unknown error’ (1): call=801, status=complete, last-rc-change=‘Wed May 6 13:39:45 2015’, queued=3556ms, exec=0ms

I can start httpd on freepbx-a and it will run for a few minutes:

[[email protected] ~]# service httpd status
httpd dead but subsys locked

You can not manually start apache. The cluster service has to.

Have you rebooted the machines?

i can manually start apache but it will eventually error out with httpd dead but subsys locked.

I just rebooted both machines within the last 5 minutes.

the update fixed the problem for me, thanks Tony.

1 Like