GUI giving error - "You don't have permission to access /.noindex.html on this server."

Full error text:
403 Forbidden

You don’t have permission to access /.noindex.html on this server.

I can get in via the console and I don’t think there’s a firewall issue blocking my access to the GUI. I checked the firewall logs (all of them, I think) and I’ve tried accessing from home and work and get the same message.

I saw a previous post that suggested fwconsole ma upgradeall --force but I’m all up to date. I tried it anyway, just to be sure, and got an ‘up to date’ response.

fwconsole restart didn’t help, nor did a full reboot of the VM running freepbx.

Any other ideas or tips?

You have port 80 set for Let’s Encrypt connections only. (In System Admin → Ports.) Use https to connect to the GUI.

I am using If I try it redirects to

Try fwconsole sa ports

Ok, that gave me:

Looks like 8080 is listening for admin connections (acp). Try http://(pbxhostname):8080/

Well… that gives a different response. If I use https I get:
This site can’t provide a secure connection

If I use http I get:
Connection timed out Error code 522

When did it work in the past, and when did it stop working?

Worked for years like this, since it was first setup. Stopped maybe 2 weeks ago, but I haven’t had a chance to deal with it until now. I think it was after an update. I suppose I can restore from a backup… Would that delete newer voicemails though?

I’d prefer to just fix it if possible.

Do you have the same result using the IP address?

Man… why didn’t I think to try that? Going in via IP (over http) works. Thanks!

Does that tell you anything about how to fix the https issue?

In this case the redirectiion looks to be side DNS (maybe)
Perhaps something like that:

http://domain is redirected to: https://your_freepbx_server (ip)

Just an idea like that.

Do you use LetsEncrypt?

Yes, I am using LetsEncrypt. I just checked (now that I’m in the GUI) and it shows that, but it’s not marked as default… I don’t remember if it’s always looked like this or not.

Hmm If I remember correctly.(I don’t use it every day).
You must set to default.
Next, you can check Sysadmin / HTTPS Setup , click on Setting tab; and check if your certificate is selected with the good one.
Or select the good one and install it.

Read the SSL Protocol like this:
fwconsole sa showSSLProtocol

You can try to reset SSL protocol if needed.
fwconsole sa resetSSLProtocol

Blockquote In this case the redirectiion looks to be side DNS (maybe)

Thanks you! I was so sure this was a freepbx issue that I wasn’t looking at anything else. Once you asked about IP and mentioned DNS I went a whole other direction and found the problem, which was DNS.


Nice to hear that.
Happy end so.

Have a nice day.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.