GUI Dashboard takes +1 minute to fully load

Good Afternoon Colleagues
I hope you are doing good and safe . I have a strange problem that i can not understand its logic . Although i can find its solution in the community , I would like to share the below notes:

  • The issue that Dashboards takes from 1 to 2 minutes to load.

  • The issue occurs on FreePBX V15 & FreePBX V16.

  • When FreePBX didn’t connect to the internet , The issue solved when setting the DNS to 127.0.0.1.

  • Sometimes when FreePBX didn’t connect to the internet , the issue didn’t appear even if 127.0.0.1 not set as DNS but what set as DNS is a local IP Address which is not DNS at all(see below).

  • When FreePBX connected to Internet , The issue solved when setting primary DNS to 127.0.0.1 and secondary & Third to any workable DNS (like 8.8.8.8 , 4.2.2.2 or even IP Address of ADSL router which is also workable DNS).

  • Also when FreePBX connected to the internet , Sometimes the issue didn’t appear when the DNS is set to IP Address of ADSL router (Which is DNS from ISP) and 127.0.0.1 is not set at all (See below).

Could you explain what is the main root cause of the issue and how to permanently solve it weather FreePBX is connected to Internet or not ?

Best Regards

Try disabling the RSS feeds and statistics sharing.

Hi Pitzkey
Thx for your replay . Kindly find my below notes:

  • I think disabling RSS feeds done by goto Settings → Advanced Settings → RSS Feeds then remove everything in the rss feed box and reload . Is that true ?
  • For Statistics Sharing , I think you mean FreePBX statistics and live network usage . Is that true ?

Best Regards

Yes, that is correct.

Hi PitzKey
Thx for your replay . I tried to disable Statistics Sharing by goto Settings → Advanced Settings → Disable collection of system statistics then set it to Yes but i can still see it at Dashboard.

May i know the correct method to disable Statistics Sharing?

Best Regards