GUI broken - Unable to run route

Asterisk: 18.16.0 is running

I just installed a script on Friday to utilize Google Clooud’s SST engine for transcribing voicemails. Everything has been working fine until this afternoon. I decided that I would modify the script to send out HTML instead of TEXT messages. I was literally at what I though was going to be one of the last steps to get the HTML voice messageis up and runnimg. I called in and left a vmail for myself but didn’t received an e-mail message. I tried a second time with the same result. The odd thing is that none of the voicemail related files get created under my /tmp folder.

When I tried to access the GUI, that is when I realized that the GUI had crashed…

Exception thrown with message “Unable to run route”

#5 Exception in /var/www/html/admin/modules/sysadmin/Network.class.php:202
#4 FreePBX\modules\Sysadmin\Network:getDefault in /var/www/html/admin/modules/sysadmin/Network.class.php:360
#3 FreePBX\modules\Sysadmin\Network:getDefaultRouteIFMacAddress in /var/www/html/admin/modules/sysadmin/Sysadmin.class.php:2189
#2 FreePBX\modules\Sysadmin:getMachineId in /var/www/html/admin/views/footer.php:104
#1 include in /var/www/html/admin/libraries/view.functions.php:151
#0 load_view in /var/www/html/admin/config.php:894

Does anyone have any suggestions on how to fix this issue?

I’ve tried a… fwconsole stop → fwconsole chown → fwconsole start which didn’t help.

I also tried fwconsole ma downloadinstall --force which didn’t help either.

My IP is excluded from FAIL2BAN and shutting the firewall down doesn’t help either.

Can someone help me try to determine what this issue is?

Todd -

When I log into an SSH window I see…

Last login: Mon Sep 11 18:17:48 2023 from

| | | ___ | ___ \ \ / /
| |
_ __ ___ ___ | |
/ /| |
/ / \ V /
| | | '__| / _ \ / _ | __/ | ___ \ /
| | | | | __/| __/| | | |
/ // /^\
_| || _| _|_| ___/ / /

NOTICE! You have 4 notifications! Please log into the UI to see them!
Current Network Configuration
sh: /sbin/ip: Permission denied
sh: /sbin/ip: Permission denied
| Interface | MAC Address | IP Addresses |
| eth0 | 00:15:5D:F0:EB:08 | |

Please note most tasks should be handled through the GUI.
You can access the GUI by typing one of the above IPs in to your web browser.
For support please visit:
Training & Support | FreePBX - Let Freedom Ring

[root@pbx ~]#

What does

ls -l $(which ip)

return ?

-rwxr-xr-x. 1 root root 470600 Dec 2 2019 /usr/sbin/ip

If from a root shell prompt, you type
/sbin/ip route
does that work as expected? If not, does
/usr/sbin/ip route
work ok?
what is the output of
ls -ld /sbin /usr/sbin

dicko and Stewart1,

Thanks for the replies offering help!!. It was just easier for me to backup the few files that I had modified and restore the VM from yesterday and then put the files back. I’ve rebooted several times and everything appears okay (at least at the moment anyway).

I’ll reply to this post if it happens again, but hopefully this was just some strange anomoly!!

Thanks again,
Todd -

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.