GSWave Android App / Remote Extension


(Rob) #1

After lots of messing around I’m finally stuck where I’m spinning my wheels and hoping for a nudge. I have FreePBX and I’m using twilio. I have the app GSWave on my android phone and when it is on the wifi it can connect and I was able to successfully make a call out and receive a call from Twilios make test call button on the site. When I try to register my phone while I am not on the wifi the app will not connect. Now I originally had an issue where if I checked to see if the port was open I would get told it is closed. To give a test I went ahead and disabled the firewall within freepbx and now a port check shows that it is open. However my phone will still not connect. So to me it seems like it is SOMETHING within FreePBX but I have no idea what. I know my sip nat is set to yes. I have the external IP address in the sip settings. I thought if I was able to run asterisk -rvvv I’d get something when the phone tries to register but nothing. Within the settings I am using a url for what it needs to point to. I know the URL is correct because I can pull up the URL on the phone in a browser and get the webgui. So I shouldn’t have a firewall issue but at this point its gotta be something I may of just missed or over looked. Any and all help is apapreciated.


(Chris Dolese) #2

id be interested to know if the sangoma connect app produces same result , have you tried it as well ?


#3

More settings details would be helpful.

GS Wave is pretty solid.

I would try TCP or TLS if your currently using UDP. Some mobile carriers muck around with SIP, and are less likely to mess with TCP.


(Rob) #4

I’d give it a shot but the sangoma connect app requires the sagnoma connect which is $150 of which I do not have to spend to try.


(Rob) #5

Which other settings are you wondering about? I did currently have it setup for UDP. I have tried TCP and TLS as well. None of which have worked. I know GS Wave to be a solid app. I used it for a while. I had everything setup but then I had shut it off for a bit. I’m not trying to bring it all back up and running so I can push my business more and have a phone number and all that tied to it. When I tried to bring up the old version and update it it was stuck in a loop and wouldnt go any further. I figured why not start from scratch. So I reinstalled everything, reconfigured my twilio trunk and tested it all locally and it worked perfectly fine. It is only when I’m coming from outside does the app not want to register.


#6

So now you’re running the Distro with FreePBX 15 and Asterisk 16? If not, provide details.

That only affects chan_sip. If your extension is not pjsip, please explain.

What router/firewall do you have? Confirm that you have forwarded UDP port 5060 (default for pjsip) and/or port 5160 (default for chan_sip) to the PBX.

Run sngrep and report what, if anything, appears when GSWave attempts to register. If nothing, do you have a way to capture traffic on the WAN interface of your router/firewall to see if it is blocking or corrupting the registration?


(Rob) #7

Yes, I’m running

FreePBX 15.0.17.24
Current Asterisk Version: 16.16.2

I am running the chan_pjsip on the extension. Tried the other just for s&gs but notta either. I’m using PFSense and I’m not seeing anything that is blocking the IP from connecting. This did work prior and i didn’t change any of the firewall rules. The only thing that has changed is the reinstallation of the FreePBX system.

I ran the sngrep and nothing was occurring. Which I would think then would lead to the firewall perhaps. But the port says it is open.


#8

Ports don’t talk. Which tool did you use from which network to probe which UDP port and what response did it get?


(Rob) #9

I used https://www.yougetsignal.com/tools/open-ports/ and put in my external wan IP and the port of 5060. I ran it from my cell phone while not connected to the wireless.


#10

That tests TCP ports only. Testing UDP would require using data for a specific application e.g. sending an OPTIONS request for SIP.

On recent FreePBX, that’s the pjsip bind port. If your extension is chan_sip, you must either reassign the port numbers or set up your app and forwarding for UDP 5160.

Also, does your pfSense get a public IP address on its WAN interface? If not, your modem is likely configured as a gateway and you would also require port forwarding there.


(Rob) #11

Ahh, I was not aware of the only TCP being sent to test for that site.

I have the extension set as a pjsip extension. The setup works on my wifi its just only when I’m outside of the network. My pfSense is connected directly to verizons ONT and gets the public IP. I have plenty of other apps forwarding ports else where that work just fine. Which is another reason I was leaning towards this being a problem with the FreePBX.


#12

See if the REGISTER requests are reaching pfSense:
https://docs.netgate.com/pfsense/en/latest/diagnostics/packetcapture/webgui.html

If not, GSWave has some debug features (I know nothing about them) that can tell you whether the requests are going to the correct IP address and port.


(Rob) #13

Hey Stewart,

Thank you very much for helping me out here. So I’m not sure what it is but with GSWave, for some reason when not on wifi it doesn’t seem like it wants to connect or do anything. I installed another app just for the fun of it and it immediately connected. I deleted the app and reinstalled it. However I went back to the play store and happened to notice that I’m not the only person that seems to have issues when using the app not on wifi. Do you recommend a better sip app for android? My only thinking with GSWave is for mobile networks you only have 2g/3G/LTE/wifi and my note 20 is 5G. I’m guessing its something with this. I tried forcing my phone on 4GLTE and still didnt work but it could be looking at something else. But if anyone else is having this issue perhaps this is the issue.


(Defcomllc) #14

Sangoma Connect works great…before making the switch to Connect 2 months ago I used Groundwire for the last year and it was excellent…not free, but only a few bucks from Play store.