Greetings in UCP not being saved v12

Hi, we have just upgraded our FreePBX instance to V12 i think it is FreePBX exactly.

The issue I am having is that I can not seem to save the professional greetings we have in the UCP.

Have converted the mp3 file inot a 16bit wav file but uploading does not provide any save function. Nor can the uploaded message be played after uploading.

When you move away from the Greeting screen and come back the upload is gone.

I have tried to record a greeting and that provides a Save function but it still wont save and can not play.

I am using Chrome. Have tried expolrer

Would appreciate some direction as to what I could possibly be doing wrong?

Anyone? Any ideas? Would be grateful for suggestions…

I had this issue too. There are a few things I had to do:

  1. No extensions start with “0”
  2. WebRTC is enabled and properly configured (with the right certificate)
  3. “Load unsafe scripts” is clicked (the shield in the URL bar when you load UCP)
  4. Voicemail is activated - that is, you have actually called and logged into VM once, and Voicemail Admin isn’t reporting [unactivated]

I can’t think of anything else at the moment…try those and let’s see if it works. I have spent over 12 hours just to come up with that little list.


Thanks ever so much. Will go through that list and report back.


Thank you for that, definitely 0 extension issue, changed to 100 and all good now.

Awesome! Glad to hear I could help you :smile: