Grandstream HT841 - FX0 connection with Free PBX

Hi there

I’m attempting to set up a Grandstream HT841 to link a FreePBX version to a PSTN connection (FXO).

Is there anyone with a functional configuration?
On the FREEPBX, I have registered a gateway port as an extension.
I’m able to successfully make outgoing calls to the PSTN using two stage dialing in HT.
It is impossible for me to receive incoming calls. This is the problem.

The HT841 sends invites to the FreePBX, but the FreePBX doesn’t send invites to the FREEPBX Extension that is called.

I use TCP transport and my extension is CHAN SIP.

192.168.45.41 - Grandstream HT841
192.168.35.22 - Free PBX

Which version? If 15 or greater, you should be using pjsip. If you are stuck with an older version, please explain.

Normally, you would register it as a trunk. Even if you get incoming working, you can’t have caller ID, because FreePBX uses the extension number (or Outbound CID) as caller ID for calls from an extension.

If this is a “new” system, I recommend UDP and pjsip, though on an old system that lacks a mature pjsip, it is possible to make a chan_sip trunk work reliably.

The defaults on FreePBX 15 and 16 are: pjsip listens on port 5060 and chan_sip on 5160. Of course, you can change those. Your trace shows the HT sending to port 5060 (configured in the HT); with default FreePBX settings that would reach pjsip (or nothing), so it’s not surprising that there is no response.

image

This system is end of life:

If at all possible, upgrade to FreePBX 16 and set up a pjsip trunk with 1-stage dialing.

If upgrade is not feasible, set up a chan_sip trunk with host=dynamic, also using 1-stage dialing.

If you still have trouble, post your settings for the new trunk and the HT, along with any relevant log.