Grandstream HT502


(Jeffrey Angus) #1

PBX Version: 15.0.16.61
PBX Distro: 12.7.6-2002-2.sng7
Asterisk Version: 16.9.0

Ext. 3009 PJSIP Fox FAX 5060
Ext. 3031 SIP Fox Payphone 5062

Two questions:

  1. Is there anything special I should do with the extensions?
  2. I need a configuration for the HT502.
    Yes, I’ve done my share of Google.
    All of the “Do this” I’ve found so far doesn’t work.
    Yes, I’m aware the HT502 is a “turd” but it supports rotary (pulse) dialing.
    Ext. 3031 is a Bell System rotary dial pay phone.

Jeff


(Jeffrey Angus) #2

Ok, apparently FX1 is working. (extension 3009)
I can call other extensions with it, and call it from them.
FX2 i

isn’t working. I get a fast busy signal if I trying calling other extensions or calling in.


#3

Change extension 3031 to use pjsip (in advanced settings for the extension, Change SIP Driver). In FXS PORT2 settings, change Primary SIP Server to
192.168.1.32:5060
and set Outbound Proxy blank for both FXS ports. Test; if you have trouble, report whether each port is registered and what happens on attempted inbound and outbound calls.


(Jeffrey Angus) #4

If I read that right, change both ports to 5060.
That did not work.
Focusing on the primary usage, to talk to a rotary dial phone.



This works, both outgoing and incoming call.


#5

For FXS port 2 (presently not registered) starting from the settings shown in your July 10 post, please change Primary SIP Server from
192.168.1.32:5062
to
192.168.1.32:5060
Also, delete the entry for Oubound Proxy (leave the box blank).
Leave local SIP port at 5062.
If you have trouble, report whether it shows registered and if not, what errors (if any) appear in the Asterisk log when it attempts to register.


(Jeffrey Angus) #6

Well, FXS1 is still working, but FXS2 is not.
No dial tone, and calling the extension results in a fast busy signal.



#7

TLS only works if you have valid certification accepted by both ends


(Jeffrey Angus) #8

Thank you.
I changed it to UDP.
That “kind of fixed it.”
I have dial tone on FXS2 now, and can call another extension from it.
However, calling that extension results in fast busy signal.


#9

FirstBaby step accomplished, now take the next one, sngrep might well help that progress.


(Jeffrey Angus) #10

Calling Extension 3009 (FXS2 on the HT502) 192.168.1.182
the PBX is 192.168.1.32
from Extension 2002 (A Digium D4) 192.168.1.235

                                       Call flow for .yADnHIL8FbNcd5NmH.N5QhSCFAcus3f (Color by Request/Response)
                                                        │INVITE sip:3009@192.168.1.32 SIP/2.0
        192.168.1.235:5060            192.168.1.32:5060 │Via: SIP/2.0/UDP 192.168.1.235:5060;rport;branch=z9hG4bKPj45YuSSHaVeoeYvyJY5QRxIV9OHSl-qB8
      ──────────┬─────────          ──────────┬─────────│Max-Forwards: 70
                │        INVITE (SDP)         │         │From: "2002" <sip:2002@192.168.1.32>;tag=tzw6ksnQWrAgcyeobotsrMVuaP5mzBma

18:58:01.898579 │ ──────────────────────────> │ │To: sip:3009@192.168.1.32
+0.053815 │ 401 Unauthorized │ │Contact: “2002” sip:2002@192.168.1.235:5060;ob
18:58:01.952394 │ <────────────────────────── │ │Call-ID: .yADnHIL8FbNcd5NmH.N5QhSCFAcus3f
+0.006961 │ ACK │ │CSeq: 10632 INVITE
18:58:01.959355 │ ──────────────────────────> │ │Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
+0.013295 │ INVITE (SDP) │ │Supported: replaces, 100rel, timer, norefersub
18:58:01.972650 │ ──────────────────────────> │ │Session-Expires: 1800
+0.110529 │ 100 Trying │ │Min-SE: 90
18:58:02.083179 │ <────────────────────────── │ │User-Agent: Digium D40 2_9_8
+0.699697 │ 503 Service Unavailable │ │Content-Type: application/sdp
18:58:02.782876 │ <────────────────────────── │ │Content-Length: 499
│ │ │
│ │ │v=0
│ │ │o=- 290055971 290055971 IN IP4 192.168.1.235
│ │ │s=digphn
│ │ │b=AS:84
│ │ │t=0 0
│ │ │a=X-nat:0
│ │ │m=audio 4006 RTP/AVP 0 8 9 111 18 58 118 58 96
│ │ │c=IN IP4 192.168.1.235
│ │ │b=TIAS:64000
│ │ │a=rtcp:4007 IN IP4 192.168.1.235
│ │ │a=sendrecv
│ │ │a=rtpmap:0 PCMU/8000
│ │ │a=rtpmap:8 PCMA/8000
│ │ │a=rtpmap:9 G722/8000
│ │ │a=rtpmap:111 G726-32/8000
│ │ │a=rtpmap:18 G729/8000
│ │ │a=rtpmap:58 L16/16000
│ │ │a=rtpmap:118 L16/8000
│ │ │a=rtpmap:58 L16-256/16000
│ │ │a=rtpmap:96 telephone-event/8000
│ │ │a=fmtp:96 0-16
│ │ │a=ssrc:56885310 cname:2036aebd36e28212


#11

You need to look at the Session from a higher level, an initial 401 is always expected, what where the next exchanges. sngrep allows you to ‘drill down’ from the initial “session” (you are only interested in INVITES), which would expose all the packet exchanges , further each packet can then be more closely inspected. there is ‘help’ just a ? away


(Jeffrey Angus) #12

True, ? worked, but the help is much like a Unix man page. It assumes you already know what you’re doing and just need to be reminded the magic number (or letter as it were.)
Actually, I’m surprised I got as far as I did with the sngrep command.

I’ll be happy to harvest the information if you tell me how to get it.


#13

Sorry, I can help with fishing lessons but I won’t do your fishing for you. because one ‘you’ easily becomes everyone. However one ‘you’ CAN be an ‘everyman’ and ultimately pay back.

When lost there is always the ‘paid for’ Support, linked to at the top of this page.


(Jeffrey Angus) #14

You’re a real piece of work.

I have the Grandstream HT502, a pair of Cisco ATAs and a Sipura.
None of which I have been able to get line-2 to work.

I had a requirement for three analog phones.
I ended up using The Grandstream, one of the Cisco and the Sipura as single line ATAs.

Both on the forums, and via Google search, the standard results are “Do this” and it doesn’t.

I have all three analog phones working now.
A 1910 Strowger PAX candlestick, my HP 8610 all-in-one printer (FAX) and a Crosley reproduction payphone.


#15

There should be no problem using Line 2 on these ATAs. The two lines of course need to have different extension numbers. They also need different local ports, though that is the default.

If the second line doesn’t register, please paste a log of the registration attempt at pastebin.freepbx.org, after setting:
pjsip set logger on
or
sip set debug on
according to extension type.

If it registers ok, paste logs for failing inbound and/or outbound calls.


(Jeffrey Angus) #16

Well, that’s just it. “Should be no problem” but it was.
They had two different extension numbers, Line-1 was pjsip 5060 and line-2 was sip 5061.
Line-1 would register, and line-2 never did on all four ATAs.


#17

The screenshot you posted for the 502 had SIP Registration: No, so of course it wouldn’t register. The question is why it wouldn’t register when you set it to Yes (the default).

Please turn that on and provide a log (with SIP trace) of attempted registration. If the extension configuration has any non-default settings other than extension number and secret, please provide details.


(Jeffrey Angus) #18

The HT-502 is working as a single line ATA at the moment, I’d rather not mess with it.


(Jared Busch) #19

Just because you do things wrong and do not understand does not mean the people helping you were wrong. Even @dicko
I do not have any 502’s in the wild with an active client. but I have the 704 all over the place as well as 802’s.

They all work without problem from default config and simply adding the SIP server and then the extension creds.

Your firmware as depicted in the screenshots looks original. That is a super basic issue.
http://www.grandstream.com/support/firmware
image

Edit: I looked the dates up.
Seriously man. Not original, but dang near.

And the current firmware is two years old. No excuse not to be using that already.


(Jeffrey Angus) #20

I had read elsewhere, a warning about updated software.
The possibility that something changes and no longer works.
In my case that would be responding to rotary pulse dialing.
“If it ain’t broke, don’t fix it.”

And it’s not just the HT502, I have three different Cisco ATAs, and guess what, they won’t do two lines either.

Either with the “default” config or with as found on the web “Do this and it works.” It doesn’t.

My “man cave” is at the other end of a Ubiquiti 5 GHz link, so I use Digium D-40 phones.
But I have three analog phones.
A 1919 Strowger candlestick, a Crosley reproduction pay phone, and an HP 8610 FAX machine.

So, there was a simple solution that’s been working quite well for the past two months.
The HT-502 for the rotary phone, and two of the Ciscos for the pay phone and FAX.

The problem with forums is there is always one “expert” that insists on giving half answers, then when you ask for a clarification determines you’re too stupid to help and says things like “I’m not going to do your work for you.”
Yeah, real helpful.