Grandstream GXW4108 FXO - only connect with 'two stage dialing'?


#1

I’ve recently setup an Asterisk based system using the latest Asterisk now installer - FreePBX 2.11.0.0 currently installed.
I am in the UK connecting to standard POTS lines.

I’ve got a Grandstream GXW4108 FXO box which we are initially planning to use on existing analogues lines as we update an internal CRM system to provide automatic dialling - I expect we’ll move to pure IP in time.
Grandstream software details ( Program–1.3.4.13 Loader–1.1.3.4 Boot–1.1.3.2 )

Currently, if I set the GXW4108 to use “two stage dialling”, I can dial the number - which then gives me a dial tone. If I then dial again, I am correctly connected.
With one stage dialling it goes straight to the POTS ‘please check and dial again’ message.

No trunk dialling plan and outbound route set to “X.”.

Any solutions/obvious stuff I’m missing/general ideas?


#2

Sorry, I know nothing about the Grandstream device but have used Linksys SPA3102 and Obihai OBi110 with Asterisk.

Possible troubles:

  1. Asterisk isn’t sending number correctly; check with “sip set debug ip (deviceipaddress)”.

  2. Device dial plan is doing undesired rewrite of the number. Does device show last dialed number in web interface and/or syslog? If not, you might record the audio, listen with a butt set, or temporarily connect to some FXS device that will show the number.

  3. Insufficient wait for dial tone. Set e.g. 3 seconds for testing.

  4. DTMF tone duration or spacing is inadequate. Set e.g. 200 ms on and 200 ms off for testing.


#3

Cheers - couldn’t test things out until today.

I had previously checked the number was being sent correctly and it was.

So all dial plans were fine.

I’d already tried playing with the dial tone and it was set to 2.5 seconds as it was.

DTMF tone duration was set to work from Asterisk. Tried changing some stuff and still not working.
Made a 3 way plug so we could replicate a butt phone, played about a bit more, getting it back to pretty much the default and it’s working correctly now!

Cheers for the help, much appreciated.


(Daniel Salazar) #4

Hi!!
I have a working GXW4104. My current configuration is as follow:
Trunk

Outbound Routes

Inbound Routes

In the GXW4104 or GXW4108

Use DEFAULThere

Leave ALL BLANK here, because We are configurating the GXW410x as a PEER and not with a SIP account.

Channel Setting

DIALING

Check With this configuration, Use a softphone to test (zoiper or xlite for example).

Hope this help, this took me 15 minutes of my life jaja.
Greetings from Chile!!


Inbound calls not working on Grandstream GXW4108
(Kparrish) #5

I know this is an older post, but you sir, are a life saver!!!

Thank you for this great step-by-step walk-through.


(Jp26198926) #6

Hi Sir, I know this is already an old post am trying to view the picture attachment of your guide but it did not show anymore.