Grandstream GXW4104 - Need help getting me across the finish line!

OK, I have set up a Grandstream GXW4104. Using it at a remote site connected to a PSTN, and want to get it to work with my FreePBX box as a SIP trunk. When I attempt to call the phone number that is connected to the GrandStream, I am getting FreePBX errors on my console as follows:

[2017-03-07 13:14:30] NOTICE[4334]: res_pjsip/pjsip_distributor.c:525 log_failed_request: Request ‘INVITE’ from ‘“WIRELESS CALLER” sip:[email protected]’ failed for ‘10.1.1.15:5060’ (callid: [email protected]) - No matching endpoint found
[2017-03-07 13:14:30] NOTICE[16227]: res_pjsip/pjsip_distributor.c:525 log_failed_request: Request ‘INVITE’ from ‘“WIRELESS CALLER” sip:[email protected]’ failed for ‘10.1.1.15:5060’ (callid: [email protected]) - No matching endpoint found
[2017-03-07 13:14:30] NOTICE[16227]: res_pjsip/pjsip_distributor.c:525 log_failed_request: Request ‘INVITE’ from ‘“WIRELESS CALLER” sip:[email protected]’ failed for ‘10.1.1.15:5060’ (callid: [email protected]) - Failed to authenticate
[2017-03-07 13:14:30] NOTICE[22048]: res_pjsip/pjsip_distributor.c:525 log_failed_request: Request ‘INVITE’ from ‘“WIRELESS CALLER” sip:[email protected]’ failed for ‘10.1.1.15:5060’ (callid: [email protected]) - No matching endpoint found
[2017-03-07 13:14:30] NOTICE[22048]: res_pjsip/pjsip_distributor.c:525 log_failed_request: Request ‘INVITE’ from ‘“WIRELESS CALLER” sip:[email protected]’ failed for ‘10.1.1.15:5060’ (callid: [email protected]) - Failed to authenticate

Running FreePBX 10.13.66-17. My Grandstream unconditional forward is set for the same as my FreePBX Inbound Route. I have been working with Grandstream tech support, but they think it is a FPBX problem. Any help would be appreciated.

Hi,

Did you ever get this resolved?

See No incoming calls .
(The thread is about a different FXO device, but the issues are the same).

tl;dr: If you don’t need the device to register (it’s on the same LAN, connected via VPN, or it has a static public IP address) there is no trouble. You can use chan_sip with no trouble. Otherwise, you need to make some manual changes to the pjsip configuration files.

No, I did not get this working satisfactorily. I bought a Sangoma Vega, and I am using that one instead.