Grandstream GXP2160 Crashing with EPM Generated Configuration

We have a mixture of phones in our environment, including Grandstream GXP2140s and GXP2160s. There are some issues with an older version version of the firmware that have been fixed in the most recent version. Unfortunately, while the GXP2140s work happily with FreePBX on the newest firmware version, the GXP2160s do not. The phone appears to boot up just fine, but when it is taken off-hook, there is no dial tone, and the phone service crashes (viewable via the web interface). I tried manually configuring the phone through the Admin web interface (admittedly only applying a subset of what FreePBX configures), and it will happily place calls; no crashing.

While it appears this is the result of some bug in the Grandstream firmware for the 2160s, I have not made many changes to the default settings that FreePBX applies to these phones. Has anyone else had a similar issue with these? The firmware version with the issue is v1.0.7.97, which is the newest offered by Grandstream, and also the newest offered through FreePBX.

I have personally worked with all the available versions of firmware between - with the current (non edge) ver of epm (sorry not able to grab the exact version at the time of writing this) without major issue.
I have actually just went through 4 different versions between them and I still find the most stable for me being the .25. The only prob for me with the .25 is the weather does not work. But it is the most stable when it comes to blf stability.
I found with the other three versions I would need to reboot the phones every so often … sometimes once per week and other times once per month.

I worked with Grandstream support, and they were eventually able to reproduce the issue using a configuration file that I created for them using my install of FreePBX. I was unable to get any confirmation as to what in the configuration file was causing the issue, but the issue is resolved in the current beta, v1.0.8.36.

That is very interesting. I also use commercial EPM and I have not experienced those types of issues. I wonder what settings you could have had different than mine that would have caused that.
We have since standardized on and that has now taken care of our BLF issues.

They indicated that it wasn’t related to the actual settings, which would lead me to believe that it is somehow related to the format of the file.

Grandstream firmware with the fix is now released as stable. It is not in the FreePBX firmware repository yet, although there is a case open for it.

any idea when it might be available, i have been waiting for grandstream firmware updates in commercial epm for a while.


Load it up yourself as custom firmware. I did that and it works great.

Steps for installing custom firmware:

You can track the issue here:

Your issue sounds off-topic and probably needs its own thread. If it truly is this issue, it can be resolved by upgrade to the current firmware on the Grandstream phones.

Old thread, but closing the loop. The newest firmware in EPM for the Grandstream GXP 2160 has the fix for this crashing issue.