FreePBX | Register | Issues | Wiki | Portal | Support

Grandstream gxp2130 not hanging up


#1

We have Grandstream gxp2130 phones managed with the commercial endpoint manager with a fresh install of FreeBPX 14.0.5.25

All has been going according to plan (we have a similar setup with an older version of FreePBX at a different location) until we attempt to transfer calls.

The blind transfer seems to try and transfer, according to the phone’s display - but nothing appears in FreePBX. But that’s just the related issue.

When I hang up the phone nothing happens in FreePBX. It doesn’t recognize the phone hung up - ever.

This same issue happens when I perform a Page. I can make the page but when I hang up all of the paged phones remain off-hook, because the phone didn’t tell FreePBX that it hung up.

But when I dial an extension directly, talk and hang up, the phone appears to send the hangup signal properly and it appears on the Asterisk Console.

Any ideas where to start troubleshooting?

Thanks in advance,
Jason


(Lee Mason) #2

With Grandstream phones I normally start by checking the firmware and making sure it’s up to date. Check the Grandstream web site for new firmware releases.


#4

Update on this . The no-hang-up / no-disconnect issue with these phones appears to be consistent across different versions of FreePBX and different Grandstream firmware versions.

These are only internal calls - extension to extension dialing.

The only equipment used is Grandstream Phones, FreePBX 14 on a Dell R710, a Unifi 24port POE switch and pfSense.

I’m trying to nail down the issue. I will be removing the Unifi switch and use a 8-port unmanaged switch instead.

I believe this issue is related to other strange behavior I’m having with VLANs and calls dropping after being in use for 30 seconds.


#5

So … the solution is not related to VLANs or Grandstream weirdness at all.

I had to modify the Settings > Asterisk SIP Settings > NAT Settings

And manually add the 10.8.2.0 network.
My data network is 10.8.1.0/24
My voice network is 10.8.2.0/24

After applying the config everything works properly.

I guess I assumed that if Admin > System Admin > Network Settings had interfaces on networks they’d be understood to be local to the Asterisk. Also, the Firewall is configured to understand that 10.8.2.0 is a local trusted network.

For curiosity sake, details on my setup include:

pfsense as the router and DHCP server, configured LAN and VLAN 20
Unifi 24-port POE switch programmed to pass VLAN 20 on all ports
FreePBX 14 with eth0 and eth0.20
Grandstream phones programmed to VLAN 20

LAN = 10.8.1.0/24
VLAN 20 = 10.8.2.0/24

To eventually discover the trouble I mirrored all traffic from a port on the Unifi Switch to another port. Using a laptop with Wireshark I captured all packets during a phone call. I observed the phone attempting to reach the Internet to call an internal phone. The call would successfully reach my FreePBX server but it would send the BYE packets to the Internet. Upon seeing that I know there was a configuration problem with SIP which led me to the solution - Settings > Asterisk SIP Settings > NAT Settings.

I appreciate everyone’s ideas and time spent considering my situation.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.